Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN258-1 : postgresql-7.4, postgresql-8.0, postgresql vulnerability


Vulnerability Assessment Details

USN258-1 : postgresql-7.4, postgresql-8.0, postgresql vulnerability

Vulnerability Assessment Summary
postgresql-7.4, postgresql-8.0, postgresql vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- libecpg-compat2
- libecpg-dev
- libecpg4
- libecpg5
- libpgtcl
- libpgtcl-dev
- libpgtypes2
- libpq-dev
- libpq3
- libpq4
- postgresql
- postgresql-7.4
- postgresql-8.0
- postgresql-client
- postgresql-client-7.4
- postgresql-client-8.0
- postgresql-contrib
- postgresql-contrib-7.4
- postgresql-contrib-8.0
- postgresql-dev
- postgresql-doc
- postgresql-doc-7.4
- postgresql-doc-8.0
- postgresql-plperl-7.4
- postgresql-plperl-8.0
[...]

Description :

Akio Ishida discovered that the SET SESSION AUTHORIZATION command did
not properly verify the validity of its argument. An authenticated
PostgreSQL user could exploit this to crash the server.

However, this does not affect the official binary Ubuntu packages. The
crash can only be triggered if the source package is rebuilt with
assertions enabled (which is not the case in the official binary
packages).

Solution :

Upgrade to :
- libecpg-compat2-8.0.3-15ubuntu2.1 (Ubuntu 5.04)
- libecpg-dev-8.0.3-15ubuntu2.1 (Ubuntu 5.04)
- libecpg4-7.4.7-2ubuntu2.2 (Ubuntu 5.04)
- libecpg5-8.0.3-15ubuntu2.1 (Ubuntu 5.04)
- libpgtcl-7.4.7-2ubuntu2.2 (Ubuntu 5.04)
- libpgtcl-dev-7.4.7-2ubuntu2.2 (Ubuntu 5.04)
- libpgtypes2-8.0.3-15ubuntu2.1 (Ubuntu 5.04)
- libpq-dev-8.0.3-15ubuntu2.1 (Ubuntu 5.04)
- libpq3-7.4.8-17ubuntu1.1 (Ubuntu 5.04)
- libpq4-8.0.3-15ubuntu2.1 (Ubuntu 5.04)
- postgresql-7.4.7-2ubuntu2.2 (Ubuntu 5.04)
- postgresql
[...]


Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

HP ProLiant MicroServer Gen8 G1610T 2.3GHz RAM 2GB HDD 4TB (2x2TB)
$349.0
HP ProLiant MicroServer Gen8 G1610T 2.3GHz RAM 2GB HDD 4TB (2x2TB) picture 5037MR-H8TRF MICRO CLOUD (SYS-5037MR-H8TRF) Super micro Super Server
$1750.0
  5037MR-H8TRF MICRO CLOUD (SYS-5037MR-H8TRF)  Super micro Super Server pictureHP PROLIANT MICROSERVER G8 CORE I3-3240 3.4GHZ 8GB 3 X 1TB MIDLINE
$1039.0
HP PROLIANT MICROSERVER G8 CORE I3-3240 3.4GHZ 8GB 3 X 1TB MIDLINE pictureHP PROLIANT MICROSERVER G8 CORE I3-3240 3.4GHZ 4GB 1TB MIDLINE
$689.0
HP PROLIANT MICROSERVER G8 CORE I3-3240 3.4GHZ 4GB 1TB MIDLINE picture


Discussions

No Discussions have been posted on this vulnerability.