Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN249-1 : xpdf, poppler, kdegraphics vulnerabilities


Vulnerability Assessment Details

USN249-1 : xpdf, poppler, kdegraphics vulnerabilities

Vulnerability Assessment Summary
xpdf, poppler, kdegraphics vulnerabilities

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- kamera
- kcoloredit
- kdegraphics
- kdegraphics-dev
- kdegraphics-doc-html
- kdegraphics-kfile-tests
- kdvi
- kfax
- kgamma
- kghostview
- kiconedit
- kmrml
- kolourpaint
- kooka
- kpdf
- kpovmodeler
- kruler
- ksnapshot
- ksvg
- kuickshow
- kview
- kviewshell
- libkscan-dev
- libkscan1
- libpoppler-dev
- libpoppler-glib-dev
- libpoppler-qt-dev
- libpoppler0c2
- libpoppler0c2-glib
- libpoppler0c2-qt
- poppler-utils
- xp
[...]

Description :

The splash image handler in xpdf did not check the validity of
coordinates. By tricking a user into opening a specially crafted PDF
file, a possible hacker could exploit this to trigger a buffer overflow
which could lead to arbitrary code execution with the rights of
the user.

The poppler library and kpdf also contain xpdf code, and thus are
affected by the same vulnerability.

Solution :

Upgrade to :
- kamera-3.4.3-0ubuntu2.3 (Ubuntu 5.10)
- kcoloredit-3.4.3-0ubuntu2.3 (Ubuntu 5.10)
- kdegraphics-3.4.3-0ubuntu2.3 (Ubuntu 5.10)
- kdegraphics-dev-3.4.3-0ubuntu2.3 (Ubuntu 5.10)
- kdegraphics-doc-html-3.4.3-0ubuntu2.3 (Ubuntu 5.10)
- kdegraphics-kfile-tests-3.4.3-0ubuntu2.3 (Ubuntu 5.10)
- kdvi-3.4.3-0ubuntu2.3 (Ubuntu 5.10)
- kfax-3.4.3-0ubuntu2.3 (Ubuntu 5.10)
- kgamma-3.4.3-0ubuntu2.3 (Ubuntu 5.10)
- kghostview-3.4.3-0ubuntu2.3 (Ubuntu 5.10)
- kiconedit-3.4.3-0ubuntu2.3 (Ubuntu 5.10)
- k
[...]


Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

Mastering CentOS 7 Linux Server
$3.98
Mastering CentOS 7 Linux Server pictureLinux Powerful Server Administration
$3.98
Linux Powerful Server Administration pictureDell PowerEdge T320 Tower Server Intel Xeon E5 48GB RAM 6x500GB HDD SATA Linux
$349.99
Dell PowerEdge T320 Tower Server Intel Xeon E5 48GB RAM 6x500GB HDD SATA Linux pictureDell PowerEdge R710 Rack Server 2x Intel Xeon CPU 120GB RAM 146GB HDD RAID Linux
$249.99
Dell PowerEdge R710 Rack Server 2x Intel Xeon CPU 120GB RAM 146GB HDD RAID Linux picture


Discussions

No Discussions have been posted on this vulnerability.