Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN243-1 : tuxpaint vulnerability


Vulnerability Assessment Details

USN243-1 : tuxpaint vulnerability

Vulnerability Assessment Summary
tuxpaint vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- tuxpaint
- tuxpaint-data


Description :

Javier Fernández-Sanguino Peña discovered that the tuxpaint-import.sh
script created a temporary file in an insecure way. This could permit a
symlink attack to create or overwrite arbitrary files with the
rights of the user running tuxpaint.

Solution :

Upgrade to :
- tuxpaint-0.9.14-2ubuntu0.1 (Ubuntu 5.10)
- tuxpaint-data-0.9.14-2ubuntu0.1 (Ubuntu 5.10)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

Polycom SoundStation IP 6000 VoIP Conference Phone 2201-15600-001 *Tested*
$69.99
Polycom SoundStation IP 6000 VoIP Conference Phone 2201-15600-001 *Tested* pictureLot of 4 Cisco 9951 CP-9951-C-K9 Unified VOIP IP Phone
$60.0
Lot of 4 Cisco 9951 CP-9951-C-K9 Unified VOIP IP Phone pictureCortelco Yealink YEA-EHS36 Wireless Headset Adapter VoIP Business Phones/IP PBX
$47.96
Cortelco Yealink YEA-EHS36 Wireless Headset Adapter VoIP Business Phones/IP PBX pictureCisco AS535-2T1-48-AC-V Universal Gateway AS5350 2T1 NP60 48 Data/Voice VOIP
$495.0
Cisco AS535-2T1-48-AC-V Universal Gateway AS5350 2T1 NP60 48 Data/Voice VOIP picture


Discussions

No Discussions have been posted on this vulnerability.