Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN24-1 : openssl script vulnerability


Vulnerability Assessment Details

USN24-1 : openssl script vulnerability

Vulnerability Assessment Summary
openssl script vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- libssl-dev
- libssl0.9.7
- openssl


Description :

Recently, Trustix Secure Linux discovered a vulnerability in the
openssl package. The auxiliary script "der_chop" created temporary
files in an insecure way, which could permit a symlink attack to create
or overwrite arbitrary files with the rights of the user invoking
the program.

Solution :

Upgrade to :
- libssl-dev-0.9.7d-3ubuntu0.1 (Ubuntu 4.10)
- libssl0.9.7-0.9.7d-3ubuntu0.1 (Ubuntu 4.10)
- openssl-0.9.7d-3ubuntu0.1 (Ubuntu 4.10)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

672756-001 HP Original SPS-DRIVE SSD 256GB SED
$135.0
672756-001 HP Original SPS-DRIVE SSD 256GB SED  picturePNY - CS1311 240GB Internal SATA III Solid State Drive
$85.0
PNY - CS1311 240GB Internal SATA III Solid State Drive pictureMacBook Air 13.3" A1369 2011 128GB SSD Solid State Drive 655-1664 MZ-CPA1280
$66.99
MacBook Air 13.3


Discussions

No Discussions have been posted on this vulnerability.