Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN233-1 : fetchmail vulnerability


Vulnerability Assessment Details

USN233-1 : fetchmail vulnerability

Vulnerability Assessment Summary
fetchmail vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- fetchmail
- fetchmail-ssl
- fetchmailconf


Description :

Steve Fosdick discovered a remote Denial of Service vulnerability in
fetchmail. When using fetchmail in 'multidrop' mode, a malicious email
server could cause a crash by sending an email without any headers.
Since fetchmail is commonly called automatically (with cron, for
example), this crash could go unnoticed.

Solution :

Upgrade to :
- fetchmail-6.2.5-13ubuntu3.2 (Ubuntu 5.10)
- fetchmail-ssl-6.2.5-13ubuntu3.2 (Ubuntu 5.10)
- fetchmailconf-6.2.5-13ubuntu3.2 (Ubuntu 5.10)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

Intel Haswell QFRA ES i7-5960X SR20Q 8 Core 3GHz CPU Processor Confidential
$195.0
Intel Haswell QFRA ES i7-5960X SR20Q 8 Core 3GHz CPU Processor Confidential pictureHP DL360p G8 8-Core Server 2x E5-2609 2.4GHz 384GB-16 LFF 2GB RPS
$1907.62
HP DL360p G8 8-Core Server 2x E5-2609 2.4GHz 384GB-16 LFF 2GB RPS pictureHP DL360p G8 8-Core Server 2x E5-2609 2.4GHz 384GB-16 2GB RPS
$1698.84
HP DL360p G8 8-Core Server 2x E5-2609 2.4GHz 384GB-16 2GB RPS pictureHP DL360p G8 8-Core Server 2x E5-2609 2.4GHz 256GB-16 LFF 2GB RPS
$1450.02
HP DL360p G8 8-Core Server 2x E5-2609 2.4GHz 256GB-16 LFF 2GB RPS picture


Discussions

No Discussions have been posted on this vulnerability.