Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN216-1 : gtk+2.0, gdk-pixbuf vulnerabilities


Vulnerability Assessment Details

USN216-1 : gtk+2.0, gdk-pixbuf vulnerabilities

Vulnerability Assessment Summary
gtk+2.0, gdk-pixbuf vulnerabilities

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- gtk2-engines-pixbuf
- gtk2.0-examples
- libgdk-pixbuf-dev
- libgdk-pixbuf-gnome-dev
- libgdk-pixbuf-gnome2
- libgdk-pixbuf2
- libgtk2.0-0
- libgtk2.0-0-dbg
- libgtk2.0-bin
- libgtk2.0-common
- libgtk2.0-dbg
- libgtk2.0-dev
- libgtk2.0-doc


Description :

Two integer overflows have been discovered in the XPM image loader of
the GDK pixbuf library. By tricking an user into opening a specially
crafted XPM image with any Gnome desktop application that uses this
library, this could be exploited to execute arbitrary code with the
rights of the user running the application.
(CVE-2005-2976, CVE-2005-3186)

Additionally, specially crafted XPM images could cause an endless loop
in the image loader, which could be exploited to cause applications
trying to open that image to hang. (CVE-2005-2975)

Solution :

Upgrade to :
- gtk2-engines-pixbuf-2.8.6-0ubuntu2.1 (Ubuntu 5.10)
- gtk2.0-examples-2.8.6-0ubuntu2.1 (Ubuntu 5.10)
- libgdk-pixbuf-dev-0.22.0-8ubuntu0.1 (Ubuntu 5.10)
- libgdk-pixbuf-gnome-dev-0.22.0-8ubuntu0.1 (Ubuntu 5.10)
- libgdk-pixbuf-gnome2-0.22.0-8ubuntu0.1 (Ubuntu 5.10)
- libgdk-pixbuf2-0.22.0-8ubuntu0.1 (Ubuntu 5.10)
- libgtk2.0-0-2.8.6-0ubuntu2.1 (Ubuntu 5.10)
- libgtk2.0-0-dbg-2.8.6-0ubuntu2.1 (Ubuntu 5.10)
- libgtk2.0-bin-2.8.6-0ubuntu2.1 (Ubuntu 5.10)
- libgtk2.0-common-2.8.6-0ubuntu2.1 (Ubu
[...]


Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

Planet GS-4210-24PL4C Managed Rack Mount Gigabit PoE Ethernet Switch, Fiber SFP
$275.0
Planet GS-4210-24PL4C Managed Rack Mount Gigabit PoE Ethernet Switch, Fiber SFP pictureHP Ethernet 10Gb 2-Port 530SFP+ PCI-e Server Adapter 652503-b21 656244-001 Clean
$275.0
HP Ethernet 10Gb 2-Port 530SFP+ PCI-e Server Adapter 652503-b21 656244-001 Clean pictureDell S4810-ON Networking Switch 48x SFP+ 4x QSFP+ 2X PSU
$1599.0
Dell S4810-ON Networking Switch 48x SFP+  4x QSFP+ 2X PSU pictureDELL S4048-ON Switch 48x SFP+ 6x QSFP+ 2x PSU
$1499.0
DELL S4048-ON Switch 48x SFP+ 6x QSFP+ 2x PSU picture


Discussions

No Discussions have been posted on this vulnerability.