Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN213-1 : sudo vulnerability


Vulnerability Assessment Details

USN213-1 : sudo vulnerability

Vulnerability Assessment Summary
sudo vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote package "sudo" is missing a security patch.

Description :

Tavis Ormandy discovered a privilege escalation vulnerability in sudo.
On executing shell scripts with sudo, the "P4" and "SHELLOPTS"
environment variables were not cleaned properly. If sudo is set up to
grant limited sudo rights to normal users this could be exploited
to run arbitrary commands as the target user.

Updated packags for Ubuntu 4.10:

Solution :

Upgrade to :
- sudo-1.6.8p9-2ubuntu2.1 (Ubuntu 4.10)
- sudo-1.6.8p9-2ubuntu2.1 (Ubuntu 5.04)
- sudo-1.6.8p9-2ubuntu2.1 (Ubuntu 5.10)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

Dell 2.5" KF248 SAS Tray Hard Drive Caddy for PowerEdge R610 1950 2950 Servers
$9.9
Dell 2.5DELL POWEREDGE SERVER R430 4 BAY BP BACKPLANE SAS RAID CABLE PNX75 8NX75
$66.0
DELL POWEREDGE SERVER R430 4 BAY BP BACKPLANE SAS RAID CABLE PNX75 8NX75 pictureDell PowerEdge R620 2 x E5-2650, PERC H710, 4GB Ram
$979.0
Dell PowerEdge R620 2 x E5-2650, PERC H710, 4GB Ram pictureDELL POWEREDGE R610 SERVER TWO X5675 3.06GHZ 24GB 2 X 1TB SATA PERC 6/I
$999.0
DELL POWEREDGE R610 SERVER TWO X5675 3.06GHZ 24GB 2 X 1TB SATA PERC 6/I picture


Discussions

No Discussions have been posted on this vulnerability.