Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN213-1 : sudo vulnerability


Vulnerability Assessment Details

USN213-1 : sudo vulnerability

Vulnerability Assessment Summary
sudo vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote package "sudo" is missing a security patch.

Description :

Tavis Ormandy discovered a privilege escalation vulnerability in sudo.
On executing shell scripts with sudo, the "P4" and "SHELLOPTS"
environment variables were not cleaned properly. If sudo is set up to
grant limited sudo rights to normal users this could be exploited
to run arbitrary commands as the target user.

Updated packags for Ubuntu 4.10:

Solution :

Upgrade to :
- sudo-1.6.8p9-2ubuntu2.1 (Ubuntu 4.10)
- sudo-1.6.8p9-2ubuntu2.1 (Ubuntu 5.04)
- sudo-1.6.8p9-2ubuntu2.1 (Ubuntu 5.10)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

samsung 24" Flatscreen HMDI monitor
$65.99
samsung 24Targus Stylus for iPad, iPhone, iPod, Samsung Tablets, Smartphones and Other ...
$33.78
Targus Stylus for iPad, iPhone, iPod, Samsung Tablets, Smartphones and Other ... pictureSmart Leather Case Cover For Samsung Galaxy Tab E A A6 9.6"~10.1" T580 T550 T560
$13.45
Smart Leather Case Cover For Samsung Galaxy Tab E A A6 9.6Smart Leather Case Cover For Samsung Galaxy Tab E A A6 9.6"~10.1" T580 T550 T560
$13.45
Smart Leather Case Cover For Samsung Galaxy Tab E A A6 9.6


Discussions

No Discussions have been posted on this vulnerability.