Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN21-1 : libgd vulnerabilities


Vulnerability Assessment Details

USN21-1 : libgd vulnerabilities

Vulnerability Assessment Summary
libgd vulnerabilities

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- libgd-dev
- libgd-noxpm-dev
- libgd-xpm-dev
- libgd1
- libgd1-noxpm
- libgd1-xpm


Description :

Several buffer overflows have been discovered in libgd's PNG handling
functions.

If a possible hacker tricked a user into loading a malicious PNG image, they
could leverage this into executing arbitrary code in the context of
the user opening image. Most importantly, this library is commonly
used in PHP. One possible target would be a PHP driven photo website
that lets users upload images. Therefore this vulnerability might lead
to privilege escalation to a web server's rights.

Solution :

Upgrade to :
- libgd-dev-1.8.4-36ubuntu0.1 (Ubuntu 4.10)
- libgd-noxpm-dev-1.8.4-36ubuntu0.1 (Ubuntu 4.10)
- libgd-xpm-dev-1.8.4-36ubuntu0.1 (Ubuntu 4.10)
- libgd1-1.8.4-36ubuntu0.1 (Ubuntu 4.10)
- libgd1-noxpm-1.8.4-36ubuntu0.1 (Ubuntu 4.10)
- libgd1-xpm-1.8.4-36ubuntu0.1 (Ubuntu 4.10)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

HP ProLiant DL360 G7 Server 2x 3.20GHz Intel Xeon X5672 Quad Core 48Gb 2x 300Gb
$425.0
HP ProLiant DL360 G7 Server 2x 3.20GHz Intel Xeon X5672 Quad Core 48Gb 2x 300Gb pictureDELL POWEREDGE R730XD SERVER 12 BAY TWO E5-2643V4 3.4GHZ 256GB 6 X 500GB SATA H7
$10379.0
DELL POWEREDGE R730XD SERVER 12 BAY TWO E5-2643V4 3.4GHZ 256GB 6 X 500GB SATA H7 pictureDELL POWEREDGE R730XD SERVER 24 BAY TWO E5-2680V3 2.5GHZ 24GB 4 X 3TB SAS NO HDD
$6589.0
DELL POWEREDGE R730XD SERVER 24 BAY TWO E5-2680V3 2.5GHZ 24GB 4 X 3TB SAS NO HDD pictureDELL POWEREDGE R730 8 BAY E5-2650V4 2.2GHZ 32GB 2133MHZ LRDIMM 6 X 500GB SATA H7
$3549.0
DELL POWEREDGE R730 8 BAY E5-2650V4 2.2GHZ 32GB 2133MHZ LRDIMM 6 X 500GB SATA H7 picture


Discussions

No Discussions have been posted on this vulnerability.