Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN195-1 : ruby1.8 vulnerability


Vulnerability Assessment Details

USN195-1 : ruby1.8 vulnerability

Vulnerability Assessment Summary
ruby1.8 vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- irb1.8
- libbigdecimal-ruby1.8
- libcurses-ruby1.8
- libdbm-ruby1.8
- libdl-ruby1.8
- libdrb-ruby1.8
- liberb-ruby1.8
- libgdbm-ruby1.8
- libiconv-ruby1.8
- libopenssl-ruby1.8
- libpty-ruby1.8
- libracc-runtime-ruby1.8
- libreadline-ruby1.8
- librexml-ruby1.8
- libruby1.8
- libruby1.8-dbg
- libsdbm-ruby1.8
- libsoap-ruby1.8
- libstrscan-ruby1.8
- libsyslog-ruby1.8
- libtcltk-ruby1.8
- libtest-unit-ruby1.8
- libtk-ruby1.8
- libweb
[...]

Description :

The object oriented scripting language Ruby supports safely executing
untrusted code with two mechanisms: safe level and taint flag on
objects. Dr. Yutaka Oiwa discovered a vulnerability that permits
Ruby methods to bypass these mechanisms. In systems which use this
feature, this could be exploited to execute Ruby code beyond the
restrictions specified in each safe level.

Solution :

Upgrade to :
- irb1.8-1.8.1+1.8.2pre4-1ubuntu0.2 (Ubuntu 5.04)
- libbigdecimal-ruby1.8-1.8.1+1.8.2pre4-1ubuntu0.2 (Ubuntu 5.04)
- libcurses-ruby1.8-1.8.1+1.8.2pre4-1ubuntu0.2 (Ubuntu 5.04)
- libdbm-ruby1.8-1.8.1+1.8.2pre4-1ubuntu0.2 (Ubuntu 5.04)
- libdl-ruby1.8-1.8.1+1.8.2pre4-1ubuntu0.2 (Ubuntu 5.04)
- libdrb-ruby1.8-1.8.1+1.8.2pre4-1ubuntu0.2 (Ubuntu 5.04)
- liberb-ruby1.8-1.8.1+1.8.2pre4-1ubuntu0.2 (Ubuntu 5.04)
- libgdbm-ruby1.8-1.8.1+1.8.2pre4-1ubuntu0.2 (Ubuntu 5.04)
- libiconv-ruby1.8-1.8.1+1.8.2p
[...]


Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

NC364T Quad Port Gigabit Ethernet Server Adapter 436431-001 435508-B21
$15.0
NC364T Quad Port Gigabit Ethernet Server Adapter 436431-001 435508-B21 pictureLot of 2 NC364T Quad Port Gigabit Ethernet Server Adapter 436431-001 435508-B21
$25.0
Lot of 2  NC364T Quad Port Gigabit Ethernet Server Adapter 436431-001 435508-B21 pictureLenovo RD530 RD430 Server Power Supply DPS-550LBA 03X3823 36002177 Spot
$70.0
Lenovo RD530 RD430 Server Power Supply DPS-550LBA 03X3823 36002177 Spot pictureNEW HPE ProLiant DL20 G9 Intel Xeon E3-1230 v6 3.50 GHz 8GB DDR4
$199.99
NEW HPE ProLiant DL20 G9 Intel Xeon E3-1230 v6 3.50 GHz 8GB DDR4  picture


Discussions

No Discussions have been posted on this vulnerability.