Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN191-1 : unzip vulnerability


Vulnerability Assessment Details

USN191-1 : unzip vulnerability

Vulnerability Assessment Summary
unzip vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote package "unzip" is missing a security patch.

Description :

Imran Ghory found a race condition in the handling of output files.
While a file was unpacked by unzip, a local attacker with write
permissions to the target directory could exploit this to change the
permissions of arbitrary files of the unzip user.

Solution :

Upgrade to :
- unzip-5.51-2ubuntu1.2 (Ubuntu 5.04)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

SonicWALL TZ 210 Firewall Hardware Kit
$69.95
SonicWALL TZ 210 Firewall Hardware Kit pictureLot of 2 WatchGuard Firebox X1000 Firewall
$15.0
Lot of 2 WatchGuard Firebox X1000 Firewall  pictureCisco PIX 535 Firewall
$327.8
Cisco PIX 535 Firewall pictureCISCO ASA5520 Firewall Upgraded 2GB RAM [ASA 5520-BUN-K9] With Express Delivery
$237.44
CISCO ASA5520 Firewall Upgraded 2GB RAM [ASA 5520-BUN-K9] With Express Delivery picture


Discussions

No Discussions have been posted on this vulnerability.