Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN183-1 : squid vulnerabilities


Vulnerability Assessment Details

USN183-1 : squid vulnerabilities

Vulnerability Assessment Summary
squid vulnerabilities

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- squid
- squid-cgi
- squid-common
- squidclient


Description :

A Denial of Service vulnerability was discovered in the handling of
aborted requests. A remote attacker could exploit this to crash Squid
by sending specially crafted requests. (CVE-2005-2794)

Alex Masterov discovered a Denial of Service vulnerability in the
sslConnectTimeout() function. By sending specially crafted SSL
requests, a remote attacker could exploit this to crash Squid.
(CVE-2005-2796)

Solution :

Upgrade to :
- squid-2.5.8-3ubuntu1.3 (Ubuntu 5.04)
- squid-cgi-2.5.8-3ubuntu1.3 (Ubuntu 5.04)
- squid-common-2.5.8-3ubuntu1.3 (Ubuntu 5.04)
- squidclient-2.5.8-3ubuntu1.3 (Ubuntu 5.04)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

*USED* Cisco ASA5512-K9 ASA 5500 Edition Bundle Firewall w/ 6GE Data
$1165.0
*USED* Cisco ASA5512-K9 ASA 5500 Edition Bundle Firewall w/ 6GE Data pictureCISCO PIX 501 FIRE WALL
$15.0
CISCO PIX 501 FIRE WALL pictureCisco AIR-AP1041N-A-K9 Aironet 802.11g/n Fixed Autonomous Access Point
$15.0
Cisco AIR-AP1041N-A-K9 Aironet 802.11g/n Fixed Autonomous Access Point pictureSix Cisco Catalyst WS-C2960-24PC-L V02 2960 Series PoE-24 w/ ISO TESTED Reset
$199.99
Six Cisco Catalyst WS-C2960-24PC-L V02 2960 Series PoE-24 w/ ISO TESTED Reset  picture


Discussions

No Discussions have been posted on this vulnerability.