Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN182-1 : xorg, xfree86 vulnerabilities


Vulnerability Assessment Details

USN182-1 : xorg, xfree86 vulnerabilities

Vulnerability Assessment Summary
xorg, xfree86 vulnerabilities

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- lbxproxy
- libdmx-dev
- libdmx1
- libdmx1-dbg
- libdps-dev
- libdps1
- libdps1-dbg
- libfs-dev
- libfs6
- libfs6-dbg
- libice-dev
- libice6
- libice6-dbg
- libsm-dev
- libsm6
- libsm6-dbg
- libx11-6
- libx11-6-dbg
- libx11-dev
- libxau-dev
- libxau6
- libxau6-dbg
- libxaw6
- libxaw6-dbg
- libxaw6-dev
- libxaw7
- libxaw7-dbg
- libxaw7-dev
- libxaw8
- libxaw8-dbg
- libxaw8-dev
- libxcomposite-dev
- libxcomposite1
- libxco
[...]

Description :

A local privilege escalation vulnerability has been discovered in the
pixmap allocation handling of the X server. By allocating a huge
pixmap, a local user could trigger an integer overflow that resulted
in a memory allocation that was too small for the requested pixmap.
This resulted in a buffer overflow which could eventually be exploited
to execute arbitrary code with full root rights.

Solution :

Upgrade to :
- lbxproxy-6.8.2-10.1 (Ubuntu 5.04)
- libdmx-dev-6.8.2-10.1 (Ubuntu 5.04)
- libdmx1-6.8.2-10.1 (Ubuntu 5.04)
- libdmx1-dbg-6.8.2-10.1 (Ubuntu 5.04)
- libdps-dev-6.8.2-10.1 (Ubuntu 5.04)
- libdps1-6.8.2-10.1 (Ubuntu 5.04)
- libdps1-dbg-6.8.2-10.1 (Ubuntu 5.04)
- libfs-dev-6.8.2-10.1 (Ubuntu 5.04)
- libfs6-6.8.2-10.1 (Ubuntu 5.04)
- libfs6-dbg-6.8.2-10.1 (Ubuntu 5.04)
- libice-dev-6.8.2-10.1 (Ubuntu 5.04)
- libice6-6.8.2-10.1 (Ubuntu 5.04)
- libice6-dbg-6.8.2-10.1 (Ubuntu 5.04)
- libsm-dev-6.8.
[...]


Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

HPE - BLADE SERVERS 813196-B21 BL460C GEN9 E5-2660V4 2P 128GB
$8145.05
HPE - BLADE SERVERS 813196-B21 BL460C GEN9 E5-2660V4 2P 128GB pictureHP 453934-001 Proliant BL680c Gen5 Blade Server System Board w/ Tray
$49.95
HP 453934-001 Proliant BL680c Gen5 Blade Server System Board w/ Tray pictureHP 683798-001 Proliant BL660c Gen8 Blade Server System Board w/ Tray
$599.95
HP 683798-001 Proliant BL660c Gen8 Blade Server System Board w/ Tray pictureIBM FLEX SYSTEM X440 7917 FOUR E5-4603 2.0GHZ 64GB 900GB 10K SAS
$3659.0
IBM FLEX SYSTEM X440 7917 FOUR E5-4603 2.0GHZ 64GB 900GB 10K SAS picture


Discussions

No Discussions have been posted on this vulnerability.