Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN173-1 : pcre3 vulnerability


Vulnerability Assessment Details

USN173-1 : pcre3 vulnerability

Vulnerability Assessment Summary
pcre3 vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- libpcre3
- libpcre3-dev
- pcregrep
- pgrep


Description :

A buffer overflow has been discovered in the PCRE, a widely used
library that provides Perl compatible regular expressions. Specially
crafted regular expressions triggered a buffer overflow. On systems
that accept arbitrary regular expressions from untrusted users, this
could be exploited to execute arbitrary code with the rights of
the application using the library.

Solution :

Upgrade to :
- libpcre3-4.5-1.1ubuntu0.5.04 (Ubuntu 5.04)
- libpcre3-dev-4.5-1.1ubuntu0.5.04 (Ubuntu 5.04)
- pcregrep-4.5-1.1ubuntu0.5.04 (Ubuntu 5.04)
- pgrep-4.5-1.1ubuntu0.5.04 (Ubuntu 5.04)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

RCA Black 7 inch 8GB Wi-fi Dual Core Android Tablet
$40.99
RCA Black 7 inch 8GB Wi-fi  Dual Core Android Tablet pictureDell PowerEdge R720 2x E5-2650 v2 2.6Ghz 8 Core 32GB 8x 300GB 15K SAS H710
$2125.0
Dell PowerEdge R720 2x E5-2650 v2 2.6Ghz 8 Core 32GB 8x 300GB 15K SAS H710 pictureRazer Blade RZ09-01021101-R3U1 14-Inch 256GB, Intel Core i7 4th Gen,2.2GHz, 8GB
$700.0
Razer Blade RZ09-01021101-R3U1 14-Inch 256GB, Intel Core i7 4th Gen,2.2GHz, 8GB pictureAMD Opteron OS6386 SE 16 Core 2.8GHz 16MB 6.4GT/s Server CPU DL385P G8 DL585 G7
$349.95
AMD Opteron OS6386 SE 16 Core 2.8GHz 16MB 6.4GT/s Server CPU DL385P G8 DL585 G7 picture


Discussions

No Discussions have been posted on this vulnerability.