Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN154-1 : vim vulnerability


Vulnerability Assessment Details

USN154-1 : vim vulnerability

Vulnerability Assessment Summary
vim vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- kvim
- kvim-perl
- kvim-python
- kvim-tcl
- vim
- vim-common
- vim-doc
- vim-gnome
- vim-gtk
- vim-lesstif
- vim-perl
- vim-python
- vim-tcl


Description :

Georgi Guninski discovered that it was possible to construct Vim
modelines that execute arbitrary shell commands by wrapping them in
glob() or expand() function calls. If a possible hacker tricked an user to
open a file with a specially crafted modeline, he could exploit this
to execute arbitrary commands with the user's rights.

Solution :

Upgrade to :
- kvim-6.3-046+1ubuntu7.1 (Ubuntu 5.04)
- kvim-perl-6.3-046+1ubuntu7.1 (Ubuntu 5.04)
- kvim-python-6.3-046+1ubuntu7.1 (Ubuntu 5.04)
- kvim-tcl-6.3-046+1ubuntu7.1 (Ubuntu 5.04)
- vim-6.3-046+1ubuntu7.1 (Ubuntu 5.04)
- vim-common-6.3-046+1ubuntu7.1 (Ubuntu 5.04)
- vim-doc-6.3-046+1ubuntu7.1 (Ubuntu 5.04)
- vim-gnome-6.3-046+1ubuntu7.1 (Ubuntu 5.04)
- vim-gtk-6.3-046+1ubuntu7.1 (Ubuntu 5.04)
- vim-lesstif-6.3-046+1ubuntu7.1 (Ubuntu 5.04)
- vim-perl-6.3-046+1ubuntu7.1 (Ubuntu 5.04)
- vim-python-6
[...]


Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

DELL POWEREDGE R630 10 BAY TWO E5-2623V4 2.6GHZ 768GB 2TB SAS 12G H330
$10469.0
DELL POWEREDGE R630 10 BAY TWO E5-2623V4 2.6GHZ 768GB 2TB SAS 12G H330 pictureDELL POWEREDGE R430 SERVER TWO E5-2630V3 2.4GHZ 32GB NO HDD H730P
$3269.0
DELL POWEREDGE R430 SERVER TWO E5-2630V3 2.4GHZ 32GB NO HDD H730P pictureDELL POWEREDGE R730XD SERVER 12 BAY E5-2697V4 2.3GHz 192GB 4 X 4TB SATA 900GB 10
$7429.0
DELL POWEREDGE R730XD SERVER 12 BAY E5-2697V4 2.3GHz 192GB 4 X 4TB SATA 900GB 10 pictureDELL POWEREDGE R720XD SERVER 3.5 TWO E5-2609 2.40GHZ 48GB 5 X 4TB SATA H710
$3249.0
DELL POWEREDGE R720XD SERVER 3.5 TWO E5-2609 2.40GHZ 48GB 5 X 4TB SATA H710 picture


Discussions

No Discussions have been posted on this vulnerability.