Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN149-3 : mozilla-firefox vulnerabilities


Vulnerability Assessment Details

USN149-3 : mozilla-firefox vulnerabilities

Vulnerability Assessment Summary
mozilla-firefox vulnerabilities

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- mozilla-firefox
- mozilla-firefox-dom-inspector
- mozilla-firefox-locale-ca
- mozilla-firefox-locale-de
- mozilla-firefox-locale-es
- mozilla-firefox-locale-fr
- mozilla-firefox-locale-it
- mozilla-firefox-locale-ja
- mozilla-firefox-locale-nb
- mozilla-firefox-locale-pl
- mozilla-firefox-locale-tr
- mozilla-firefox-locale-uk


Description :

USN-149-1 fixed some vulnerabilities in the Ubuntu 5.04 (Hoary
Hedgehog) version of Firefox. The version shipped with Ubuntu 4.10
(Warty Warthog) is also vulnerable to these flaws, so it needs to be
upgraded as well. Please see

http://www.ubuntulinux.org/support/documentation/usn/usn-149-1

for the original advisory.

This update also fixes several older vulnerabilities
Some of them
could be exploited to execute arbitrary code with full user rights
if the user visited a malicious web site. (MFSA-2005-01 to
MFSA-2005-44
please see the following web site for details:
http://www.mozilla.org/projects/security/known-vulnerabilities.html)

Solution :

Upgrade to :
- mozilla-firefox-1.0.6-0ubuntu0.0.1 (Ubuntu 4.10)
- mozilla-firefox-dom-inspector-1.0.6-0ubuntu0.0.1 (Ubuntu 4.10)
- mozilla-firefox-locale-ca-1.0-0ubuntu0.1 (Ubuntu 4.10)
- mozilla-firefox-locale-de-1.0-0ubuntu0.1 (Ubuntu 4.10)
- mozilla-firefox-locale-es-1.0-0ubuntu0.1 (Ubuntu 4.10)
- mozilla-firefox-locale-fr-1.0-0ubuntu0.2 (Ubuntu 4.10)
- mozilla-firefox-locale-it-1.0-0ubuntu0.1 (Ubuntu 4.10)
- mozilla-firefox-locale-ja-1.0-0ubuntu0.1 (Ubuntu 4.10)
- mozilla-firefox-locale-nb-1.0-0ubuntu
[...]


Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

Obihai OBi200 1-Port VoIP Adapter with Google Voice and Fax Support for Home,FS
$43.0
Obihai OBi200 1-Port VoIP Adapter with Google Voice and Fax Support for Home,FS picture Lot of 4 Cisco SPA514G Unified 100/1000 IP VoIP Phones with handsets and stands
$70.0
 Lot of 4 Cisco SPA514G Unified 100/1000 IP VoIP Phones with handsets and stands pictureDSC-MOD-SPCI-E CYBERTECH VOIP ADAPTER DSC-MOD-SPCI-E PCIe CARD
$20.0
DSC-MOD-SPCI-E CYBERTECH VOIP ADAPTER DSC-MOD-SPCI-E PCIe CARD picturePlantronics Calisto P540-M USB Voip Phone Headset
$89.99
Plantronics Calisto P540-M USB Voip Phone Headset picture


Discussions

No Discussions have been posted on this vulnerability.