Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN149-1 : mozilla-firefox vulnerabilities


Vulnerability Assessment Details

USN149-1 : mozilla-firefox vulnerabilities

Vulnerability Assessment Summary
mozilla-firefox vulnerabilities

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- mozilla-firefox
- mozilla-firefox-dev
- mozilla-firefox-dom-inspector
- mozilla-firefox-gnome-support


Description :

Secunia.com reported that one of the recent security patches in
Firefox reintroduced the frame injection patch that was originally
known as CVE-2004-0718. This permited a malicious web site to spoof the
contents of other web sites. (CVE-2005-1937)

In several places the browser user interface did not correctly
distinguish between true user events, such as mouse clicks or
keystrokes, and synthetic events genenerated by web content. This
could be exploited by malicious web sites to generate e. g. mouse
clicks that install malicious tests. Synthetic events are now
prevented from reaching the browser UI entirely. (CVE-2005-2260)

Scripts in XBL controls from web content continued to be run even when
Javascript was disabled. This could be combined with most script-based
exploits to attack people running vulnerable versions who thought
disabling Javascript would protect them. (CVE-2005-2261)

Matthew Mastracci discovered a flaw in the addons installation
launcher. By forcing a page navigation immediately after ca
[...]

Solution :

Upgrade to :
- mozilla-firefox-1.0.2-0ubuntu5.4 (Ubuntu 5.04)
- mozilla-firefox-dev-1.0.2-0ubuntu5.4 (Ubuntu 5.04)
- mozilla-firefox-dom-inspector-1.0.2-0ubuntu5.4 (Ubuntu 5.04)
- mozilla-firefox-gnome-support-1.0.2-0ubuntu5.4 (Ubuntu 5.04)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

NPS-330AB A DELL 01859D POWEREDGE 2400 SERVER POWER SUPPLY 330W MAX
$12.0
NPS-330AB A DELL 01859D POWEREDGE 2400 SERVER POWER SUPPLY 330W MAX pictureDell Poweredge T110 II
$80.0
Dell Poweredge T110 II pictureDELL PowerEdge R320 E5-2470 2.3Ghz 8 Core, 32GB, 4x 2TB, H310, iDRAC 7, vFlash
$1200.0
DELL PowerEdge R320 E5-2470 2.3Ghz 8 Core, 32GB, 4x 2TB, H310, iDRAC 7, vFlash pictureDell PowerEdge R630 2 x E5-2630v3, PERC H330, 32GB Ram
$2449.0
Dell PowerEdge R630 2 x E5-2630v3, PERC H330, 32GB Ram picture


Discussions

No Discussions have been posted on this vulnerability.