Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN148-1 : zlib vulnerability


Vulnerability Assessment Details

USN148-1 : zlib vulnerability

Vulnerability Assessment Summary
zlib vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- zlib-bin
- zlib1g
- zlib1g-dev


Description :

Tavis Ormandy discovered that zlib did not properly verify data
streams. Decompressing certain invalid compressed files caused
corruption of internal data structures, which caused applications
which link to zlib to crash. Specially crafted input might even have
permited arbitrary code execution.

zlib is used by hundreds of server and client applications, so this
vulnerability could be exploited to cause Denial of Service attacks to
almost all services provided by an Ubuntu system.

Solution :

Upgrade to :
- zlib-bin-1.2.2-4ubuntu1.1 (Ubuntu 5.04)
- zlib1g-1.2.2-4ubuntu1.1 (Ubuntu 5.04)
- zlib1g-dev-1.2.2-4ubuntu1.1 (Ubuntu 5.04)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

Apple Macbook Pro 17" 2.2 GHz Quad i7 + 1 TB Solid State Drive + 2 TB Hard Drive
$1295.0
Apple Macbook Pro 17WD Black Dual Drive 120GB SSD & 1TB HDD
$50.0
WD Black Dual Drive 120GB SSD & 1TB HDD pictureDELL T7910 WORKSTATION E5-2620V3 2.4GHZ 32GB 2 X 1TB SATA K4000
$2949.0
DELL T7910 WORKSTATION E5-2620V3 2.4GHZ 32GB 2 X 1TB SATA K4000 pictureHP PROLIANT DL360 G6 SERVER X5570 2.93GHZ 8GB 4 X 1TB SATA
$509.0
HP PROLIANT DL360 G6 SERVER X5570 2.93GHZ 8GB 4 X 1TB SATA picture


Discussions

No Discussions have been posted on this vulnerability.