Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN133-1 : apache vulnerability


Vulnerability Assessment Details

USN133-1 : apache vulnerability

Vulnerability Assessment Summary
apache vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- apache
- apache-common
- apache-dbg
- apache-dev
- apache-doc
- apache-perl
- apache-ssl
- apache-utils
- libapache-mod-perl


Description :

A buffer overflow was discovered in the "htpasswd" utility. This could
be exploited to execute arbitrary code with the rights of the user
invoking htpasswd. This is only a security vulnerability if you have a
website that offers a public interface to htpasswd without checking
the input beforehand
however, this is very unusual.

Solution :

Upgrade to :
- apache-1.3.31-6ubuntu0.7 (Ubuntu 4.10)
- apache-common-1.3.31-6ubuntu0.7 (Ubuntu 4.10)
- apache-dbg-1.3.31-6ubuntu0.7 (Ubuntu 4.10)
- apache-dev-1.3.31-6ubuntu0.7 (Ubuntu 4.10)
- apache-doc-1.3.31-6ubuntu0.7 (Ubuntu 4.10)
- apache-perl-1.3.31-6ubuntu0.7 (Ubuntu 4.10)
- apache-ssl-1.3.31-6ubuntu0.7 (Ubuntu 4.10)
- apache-utils-1.3.31-6ubuntu0.7 (Ubuntu 4.10)
- libapache-mod-perl-1.29.0.2.0-6ubuntu0.7 (Ubuntu 4.10)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

Brocade TurboIron TI-24X-AC 24 Port 10GbE SFP+ Switch With RPS11 Foundry
$1495.0
Brocade TurboIron TI-24X-AC 24 Port 10GbE SFP+ Switch With RPS11 Foundry pictureFoundry FESX424-POE Gigabit L3 POE Switch 802.3af Fastiron Edge 24 Port + 4 SFP
$295.0
Foundry FESX424-POE Gigabit L3 POE Switch 802.3af Fastiron Edge 24 Port + 4 SFP pictureCisco Nexus N3K-C3064PQ-10GX Nexus 3064-X, 48 SFP+, 4 QSFP+ ports N3K-LAN1K9
$2495.0
Cisco Nexus N3K-C3064PQ-10GX Nexus 3064-X, 48 SFP+, 4 QSFP+ ports N3K-LAN1K9  pictureFoundry Fastiron Edge FESX424HF-PREM Full Layer 3 SFP GbE Switch 10GbE Option
$245.0
Foundry Fastiron Edge FESX424HF-PREM Full Layer 3 SFP GbE Switch 10GbE Option  picture


Discussions

No Discussions have been posted on this vulnerability.