Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN105-1 : php4 vulnerabilities


Vulnerability Assessment Details

USN105-1 : php4 vulnerabilities

Vulnerability Assessment Summary
php4 vulnerabilities

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- libapache2-mod-php4
- php4
- php4-cgi
- php4-curl
- php4-dev
- php4-domxml
- php4-gd
- php4-ldap
- php4-mcal
- php4-mhash
- php4-mysql
- php4-odbc
- php4-pear
- php4-recode
- php4-snmp
- php4-sybase
- php4-xslt


Description :

Two Denial of Service vulnerabilities have been discovered in the
getimagesize() function. getimagesize() uses format specific internal
functions php_handle_iff() and php_handle_jpeg() which get stuck in
infinite loops when certain (invalid) size parameters are read from
the image. In web applications that permit users to upload arbitrary
image files, a remote attacker could render the server unavailable by
uploading specially crafted images.

Solution :

Upgrade to :
- libapache2-mod-php4-4.3.8-3ubuntu7.7 (Ubuntu 4.10)
- php4-4.3.8-3ubuntu7.7 (Ubuntu 4.10)
- php4-cgi-4.3.8-3ubuntu7.7 (Ubuntu 4.10)
- php4-curl-4.3.8-3ubuntu7.7 (Ubuntu 4.10)
- php4-dev-4.3.8-3ubuntu7.7 (Ubuntu 4.10)
- php4-domxml-4.3.8-3ubuntu7.7 (Ubuntu 4.10)
- php4-gd-4.3.8-3ubuntu7.7 (Ubuntu 4.10)
- php4-ldap-4.3.8-3ubuntu7.7 (Ubuntu 4.10)
- php4-mcal-4.3.8-3ubuntu7.7 (Ubuntu 4.10)
- php4-mhash-4.3.8-3ubuntu7.7 (Ubuntu 4.10)
- php4-mysql-4.3.8-3ubuntu7.7 (Ubuntu 4.10)
- php4-odbc-4.3.8-3
[...]


Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

Catalyst 2960 Series - 48 Port Gigabit Switch - WS-C2960-48TC-L V02
$28.5
Catalyst 2960 Series  -  48 Port Gigabit Switch  -  WS-C2960-48TC-L V02 pictureCisco SF300-24 Managed Ethernet Switch 24-Port 10/100 POE
$19.95
Cisco SF300-24 Managed Ethernet Switch 24-Port 10/100 POE pictureNew Cisco Nexus 2232PP 10GE Fabric Extender 32-Port SFP Switch N2K-C2232PP-10GE
$299.95
New Cisco Nexus 2232PP 10GE Fabric Extender 32-Port SFP Switch N2K-C2232PP-10GE picturePakedge Device & Software SW24-GBM 24-Port Gigabit AVB Managed Switch
$70.0
Pakedge Device & Software SW24-GBM 24-Port Gigabit AVB Managed Switch picture


Discussions

No Discussions have been posted on this vulnerability.