Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Tomcat's snoop servlet gives too much information


Vulnerability Assessment Details

Tomcat's snoop servlet gives too much information

Vulnerability Assessment Summary
Searches for the existence of /examples/jsp/snp/anything.snp

Detailed Explanation for this Vulnerability Assessment

The 'snoop' tomcat's servlet is installed.
(/examples/jsp/snp/anything.snp)

This servlet gives too much information about
the remote host, such as the PATHs in use,
the host kernel version and so on...

This permits a possible hacker to gain more knowledge
about this host, and make more precise attacks
thanks to this.

Solution : delete this servlet

Network Security Threat Level: Low

Networks Security ID: 1532

Vulnerability Assessment Copyright: This script is Copyright (C) 2000 Renaud Deraison

Cables, Connectors

IBM BladeServer HS21 XM 7995HVU, 2x Xeon E5450, 8x 4G ECC DDR2, Qlogic 4Gb Fiber
$149.57
IBM BladeServer HS21 XM 7995HVU, 2x Xeon E5450, 8x 4G ECC DDR2, Qlogic 4Gb Fiber pictureIBM BLADECENTER E 14 X HS22 BLADES WITH 2 X QC E5506 48GB RAM 2 X 300GB 7870-AC1
$16669.0
IBM BLADECENTER E 14 X HS22 BLADES WITH 2 X QC E5506 48GB RAM 2 X 300GB 7870-AC1 pictureIBM BLADECENTER E 14 X HS22 BLADES WITH 2 X 6C X5650 48GB RAM 2 X 300GB 7870-AC1
$29019.0
IBM BLADECENTER E 14 X HS22 BLADES WITH 2 X 6C X5650 48GB RAM 2 X 300GB 7870-AC1 pictureIBM BLADECENTER E 14 X HS22 BLADES WITH 2 X 6C X5660 48GB RAM 2 X 300GB 7870-AC1
$30539.0
IBM BLADECENTER E 14 X HS22 BLADES WITH 2 X 6C X5660 48GB RAM 2 X 300GB 7870-AC1 picture


Discussions

No Discussions have been posted on this vulnerability.