Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain root remotely >> Tinyproxy heap overflow


Vulnerability Assessment Details

Tinyproxy heap overflow

Vulnerability Assessment Summary
proxy server heap overflow

Detailed Explanation for this Vulnerability Assessment

It was possible to make the remote service crash
by sending it the command :

connect AAA[...]AAAA://


It may be possible for a possible hacker to execute arbitrary code
on this host thanks to this flaw.

Solution : if you are using tinyProxy, then upgrade to version 1.3.3a, or else
contact your vendor for a patch
Network Security Threat Level: High

Networks Security ID: 2217

Vulnerability Assessment Copyright: This script is Copyright (C) 2000 Renaud Deraison

Cables, Connectors

Dell Inspiron 560 Pentium Dual-Core 3.2GHz CPU 4GB Ram 500GB HDD No OS Computer
$79.99
Dell Inspiron 560 Pentium Dual-Core 3.2GHz CPU 4GB Ram 500GB HDD No OS Computer pictureTESTED HP ProBook 4520s motherboard 598668-001 with CPU and fan
$38.88
TESTED HP ProBook 4520s motherboard 598668-001 with CPU and fan picture4 x Intel SLG9K Xeon-E7450 2.4GHz/12MB/1066MHz Socket 604 6-Core CPU - matched
$22.4
4 x Intel SLG9K Xeon-E7450 2.4GHz/12MB/1066MHz Socket 604 6-Core CPU - matched  pictureAMD Opteron 170 2GHz Dual-Core Processor, OSA170DAA6CD, Socket 939
$29.95
AMD Opteron 170 2GHz Dual-Core Processor, OSA170DAA6CD, Socket 939 picture


Discussions

No Discussions have been posted on this vulnerability.