Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> TikiWiki < 1.8.6 / 1.9.1 Multiple Vulnerabilities


Vulnerability Assessment Details

TikiWiki < 1.8.6 / 1.9.1 Multiple Vulnerabilities

Vulnerability Assessment Summary
Checks for multiple vulnerabilities in TikiWiki < 1.8.6 / 1.9.1

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that is affected by
multiple vulnerabilities.

Description :

The remote host is running TikiWiki, an open-source wiki application
written in PHP.

The version of TikiWiki installed on the remote host fails to sanitize
input to the 'language' parameter of the 'tiki-user_preferences.php'
script before using it in a PHP 'include' function. An authenticated
attacker can leverage this issue by specifying a path with directory
traversal sequences to read arbitrary files and possibly execute
arbitrary PHP code on the remote host, subject to the rights of
the web server user id.

In addition, it also fails to sanitize input to the 'suck_url'
parameter of the 'tiki-editpage.php' script before using it to read
files. With a specially-crafted request, an unauthenticated attacker
can exploit this issues to read arbitrary files on the remote host.

See also :

http://www.idefense.com/application/poi/display?id=335&type=vulnerabilities
http://www.idefense.com/application/poi/display?id=337&type=vulnerabilities
http://sourceforge.net/project/shownotes.php?release_id=350764

Solution :

Upgrade to TikiWiki 1.8.6 / 1.9.1 or later.

Network Security Threat Level:

Medium / CVSS Base Score : 4.7
(AV:R/AC:L/Au:NR/C:P/I:P/A:N/B:N)

Networks Security ID: 15390, 15392

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2006 Tenable Network Security

Cables, Connectors

HP PROLIANT BL465C G8 SERVER TWO 6378 2.4GHZ 128GB 1TB SATA
$3369.0
HP PROLIANT BL465C G8 SERVER TWO 6378 2.4GHZ 128GB 1TB SATA pictureDELL POWEREDGE M630 E5-2640V3 2.6GHZ 64GB NO HDD H730
$2569.0
DELL POWEREDGE M630 E5-2640V3 2.6GHZ 64GB NO HDD H730 pictureDELL POWEREDGE M620 BLADE TWO E5-2630LV2 2.40GHZ 64GB 2 X 1.2TB 10K SAS H710
$1779.0
DELL POWEREDGE M620 BLADE TWO E5-2630LV2 2.40GHZ 64GB 2 X 1.2TB 10K SAS H710 pictureDELL POWEREDGE M630 E5-2698V4 2.2GHZ 256GB 2 X 1.6TB SSD S130
$7219.0
DELL POWEREDGE M630 E5-2698V4 2.2GHZ 256GB 2 X 1.6TB SSD S130 picture


Discussions

No Discussions have been posted on this vulnerability.