Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Sympa wwsympa do_search_list Overflow DoS


Vulnerability Assessment Details

Sympa wwsympa do_search_list Overflow DoS

Vulnerability Assessment Summary
Checks for sympa version

Detailed Explanation for this Vulnerability Assessment

The remote host is running SYMPA, an open source mailing list software.

This version of Sympa has a flaw in one of it's scripts (wwsympa.pl) which
would permit a remote attacker to overflow the sympa server. Specifically,
within the cgi script wwsympa.pl is a do_search_list function which fails to perform
bounds checking. A possible hacker, passing a specially formatted long string
to this function, would be able to crash the remote sympa server. At the
time of this writing, the attack is only known to cause a Denial of Service
(DoS).

Solution : Update to version 4.1.2 or newer

See also: http://www.sympa.org/

Network Security Threat Level: Medium

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 David Maciejak

Cables, Connectors

Cisco WS-C3850-12S-S 12 Port GE SFP IP Base dual PWR-C1-350WAC WARRANTY RACK
$2188.0
Cisco WS-C3850-12S-S 12 Port GE SFP IP Base dual PWR-C1-350WAC WARRANTY RACK  pictureMOLEX 74742-0001 Small Form-factor Pluggable (SFP) Cable Assembly
$20.0
MOLEX 74742-0001 Small Form-factor Pluggable (SFP) Cable Assembly pictureNTTP51AF, NORTEL GE SX/FC100 MX SFP
$75.0
NTTP51AF, NORTEL GE SX/FC100 MX SFP pictureAddOn HP JD089B Compatible SFP Transceiver
$82.9
AddOn HP JD089B Compatible SFP Transceiver picture


Discussions

No Discussions have been posted on this vulnerability.