Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> SugarCRM <= 4.2.0a Multiple Remote File Include Vulnerabilities


Vulnerability Assessment Details

SugarCRM <= 4.2.0a Multiple Remote File Include Vulnerabilities

Vulnerability Assessment Summary
Tries to read a local file using SugarCRM

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that is affected by
multiple remote file inclusion issues.

Description :

The version of SugarCRM installed on the remote host fails to sanitize
input to various parameters and scripts before using it to include PHP
code from other files. Provided PHP's 'register_globals' setting is
enabled, an unauthenticated attacker may be able to exploit these
issues to view arbitrary files on the remote host or to execute
arbitrary PHP code, possibly taken from third-party hosts.

See also :

http://retrogod.altervista.org/sugar_suite_42_incl_xpl.html
http://www.securityfocus.com/archive/1/434009/30/0/threaded
http://www.sugarcrm.com/forums/showthread.php?t=12282

Solution :

Unknown at this time.

Network Security Threat Level:

Medium / CVSS Base Score : 4.7
(AV:R/AC:L/Au:NR/C:P/I:P/A:N/B:N)

Networks Security ID: 17987

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

Brainboxes Device Server ES-511
$263.72
Brainboxes Device Server ES-511 pictureLexmark MarkNet N8352 802.11b/g/n Wireless Print Server Kit 27X0125
$49.0
Lexmark MarkNet N8352 802.11b/g/n Wireless Print Server Kit 27X0125 pictureIntel Ethernet Server Adapter I210 I210T1
$78.4
Intel Ethernet Server Adapter I210 I210T1 pictureDell PowerEdge R510 2x E5620 2.4GHz Quad Core 32GB 12x 600GB 15K SAS PERC H700
$3275.0
Dell PowerEdge R510 2x E5620 2.4GHz Quad Core 32GB 12x 600GB 15K SAS PERC H700 picture


Discussions

No Discussions have been posted on this vulnerability.