Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Stronghold Swish


Vulnerability Assessment Details

Stronghold Swish

Vulnerability Assessment Summary
Searches for the existence of cgi-bin/search

Detailed Explanation for this Vulnerability Assessment

An information disclosure vulnerability was reported in a
sample script provided with Red Hat's Stronghold web server.
A remote user can acertain the web root directory path.

A remote user can send a request to the Stronghold sample script
swish to cause the script to reveal the full path to the webroot directory.

Apparently, swish may also display system-specific information in the
HTML returned by the script

Solution : remove it
Network Security Threat Level: Low

Networks Security ID: 4785

Vulnerability Assessment Copyright: This script is Copyright (C) 2003 Randy Matz

Cables, Connectors

DELL POWEREDGE R520 SERVER TWO E5-2403V2 1.8GHZ 192GB 5 X 300GB 15K SAS H710P
$4239.0
DELL POWEREDGE R520 SERVER TWO E5-2403V2 1.8GHZ 192GB 5 X 300GB 15K SAS H710P pictureDELL POWEREDGE R520 SERVER E5-2420V2 2.2GHZ 12GB 7 X 600GB 15K SAS H710
$3469.0
DELL POWEREDGE R520 SERVER E5-2420V2 2.2GHZ 12GB 7 X 600GB 15K SAS H710 pictureDELL POWEREDGE R520 SERVER E5-2430V2 2.5GHZ 16GB 5 X 300GB 15K SAS H710
$1999.0
DELL POWEREDGE R520 SERVER E5-2430V2 2.5GHZ 16GB 5 X 300GB 15K SAS H710 pictureDELL POWEREDGE R520 SERVER TWO E5-2430 2.20GHZ 96GB 8 X 146GB 15K SAS H710P
$3229.0
DELL POWEREDGE R520 SERVER TWO E5-2430 2.20GHZ 96GB 8 X 146GB 15K SAS H710P picture


Discussions

No Discussions have been posted on this vulnerability.