Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> SquirrelCart SQL Injection


Vulnerability Assessment Details

SquirrelCart SQL Injection

Vulnerability Assessment Summary
SQL Injection in Squirrelcart

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that is subject to
SQL injection attacks.

Description :

The remote host is running SquirrelCart, a shopping cart program
written in PHP.

There is a flaw in the remote software that may permit anyone to inject
arbitrary SQL commands, which may in turn be used to gain
administrative access on the remote host.

SquirrelCart 1.5.5 and prior versions are affected by this flaw.

See also :

http://www.ldev.com/forums/showthread.php?t=1860

Solution :

Upgrade to SquirrelCart 1.6.0 or download a patch from
SquirrelCart.com.

Network Security Threat Level:

Medium / CVSS Base Score : 5
(AV:R/AC:L/Au:NR/C:P/A:N/I:P/B:N)

Networks Security ID: 12944

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2006 Tenable Network Security

Cables, Connectors

Dell OptiPlex 9020 SFF Computer Core i5-4570 Quad Core 3.2GHz 8GB 1TB USB3.0
$179.0
Dell OptiPlex 9020 SFF Computer Core i5-4570 Quad Core 3.2GHz 8GB 1TB USB3.0 pictureApple 2010 MacPro Tower 5.1 3.33GHz 6 Core 500gb ssd 1TB 32Gb MC560LL/A CTO
$729.99
Apple 2010  MacPro Tower 5.1 3.33GHz 6 Core 500gb ssd 1TB 32Gb MC560LL/A CTO pictureApple Mac Pro Tower 5.1 intel 12-Core 3.46GHz 1Tb 64gb GTX 980TI 6GB
$1549.99
Apple Mac Pro Tower 5.1 intel 12-Core 3.46GHz 1Tb 64gb GTX 980TI 6GB picture


Discussions

No Discussions have been posted on this vulnerability.