Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain a shell remotely >> SpamAssassin Arbitrary Command Execution Vulnerability


Vulnerability Assessment Details

SpamAssassin Arbitrary Command Execution Vulnerability

Vulnerability Assessment Summary
Checks for an command execution flaw in spamd

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote server permits execution of arbitrary commands.

Description :

The remote host is running spamd, a daemon belonging to SpamAssassin
and used to acertain whether messages represent spam.

The installed version of spamd on the remote host appears to permit an
unauthenticated user to execute arbitrary commands, subject to the
rights of the user under which it operates.

See also :

http://spamassassin.apache.org/advisories/cve-2006-2447.txt

Solution :

Upgrade to SpamAssassin 3.0.6 / 3.1.3 or later.

Network Security Threat Level:

Medium / CVSS Base Score : 5.6
(AV:R/AC:H/Au:NR/C:P/I:P/A:P/B:N)

Networks Security ID: 18290

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

IBM HS22 BLADECENTER SERVER E5640 2.66GHZ 16GB 2 X 600GB 10K SAS
$1379.0
IBM HS22 BLADECENTER SERVER E5640 2.66GHZ 16GB 2 X 600GB 10K SAS pictureDELL POWEREDGE M710 SERVER TWO E5620 2.40GHZ 128GB 1.6TB SSD SAS 6/IR
$1839.0
DELL POWEREDGE M710 SERVER TWO E5620 2.40GHZ 128GB 1.6TB SSD SAS 6/IR pictureDELL POWEREDGE M910 SERVER TWO E7-8837 2.66GHZ 256GB 2 X 600GB SSD
$3439.0
DELL POWEREDGE M910 SERVER TWO E7-8837 2.66GHZ 256GB 2 X 600GB SSD picture


Discussions

No Discussions have been posted on this vulnerability.