Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Misc. >> SheerDNS directory traversal


Vulnerability Assessment Details

SheerDNS directory traversal

Vulnerability Assessment Summary
Acertains if the remote DNS server handles malformed names

Detailed Explanation for this Vulnerability Assessment

The remote server seems to be running SheerDNS 1.0.0 or older.

This version is vulnerable to several flaws permiting :
- A remote attacker to read certain files with predefined names
(A, PTR, CNAME, ...)

- A local attacker to read the first line of arbitrary files with the
rights of the DNS server (typically root)

- A local attacker to execute arbitrary code through a buffer overflow

Solution : Upgrade to SheerDNS 1.0.1 or disable this service
Network Security Threat Level: Low (remotely) / High (locally)

Networks Security ID: 7335, 7336

Vulnerability Assessment Copyright: This script is Copyright (C) 2003 Renaud Deraison

Cables, Connectors

Vintage Commodore Amiga 3000 A3000 Desktop PC Personal Computer Workstation
$599.99
Vintage Commodore Amiga 3000 A3000 Desktop PC Personal Computer Workstation pictureKoronis Rift sealed commodore 64/128 or atari disk 1985 nr factory sealed
$0.99
Koronis Rift sealed commodore 64/128 or atari disk 1985 nr factory sealed pictureVIC-1915 Commodore vic-20 game cartridge PIRATES COVE Vintage Game
$22.04
VIC-1915 Commodore vic-20 game cartridge PIRATES COVE Vintage Game  pictureVINTAGE VIC-20 CASSETTE SOFTWARE ROBERT CARRIER MENU PLANNER 04346700170 RARE
$17.99
VINTAGE VIC-20 CASSETTE SOFTWARE ROBERT CARRIER MENU PLANNER 04346700170 RARE picture


Discussions

No Discussions have been posted on this vulnerability.