Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> SMTP problems >> Sendmail buffer overflow due to type conversion


Vulnerability Assessment Details

Sendmail buffer overflow due to type conversion

Vulnerability Assessment Summary
Checks the version number

Detailed Explanation for this Vulnerability Assessment

The remote sendmail server, according to its version number,
may be vulnerable to a remote buffer overflow permiting remote
users to gain root rights.

Sendmail versions from 5.79 to 8.12.8 are vulnerable.
Solution : Upgrade to Sendmail ver 8.12.9 or greater or
if you cannot upgrade, apply patches for 8.10-12 here:

http://www.sendmail.org/patchps.html

NOTE: manual patches do not change the version numbers.
Vendors who have released patched versions of sendmail
may still falsely show vulnerability.

*** Nessus reports this vulnerability using only
*** the banner of the remote SMTP server. Therefore,
*** this might be a false positive.

Network Security Threat Level: High

Networks Security ID: 7230

Vulnerability Assessment Copyright: This script is Copyright (C) 2003 Renaud Deraison

Cables, Connectors

Cherry Keyboard 68 Keys White Backlight Mechanical Steampunk Vintage Typewriter
$84.8
Cherry Keyboard 68 Keys White Backlight Mechanical Steampunk Vintage Typewriter pictureLot of 4 Manuals for TRS 80 Vtg Computer RS232 Interface Memory Expansion
$20.0
Lot of 4 Manuals for TRS 80 Vtg Computer RS232 Interface Memory Expansion pictureVintage Apple iMac M5521 15" Bondi Blue AIO PowerPC G3 350MHz 64MB RAM 40GB HD
$10.72
Vintage Apple iMac M5521 15


Discussions

No Discussions have been posted on this vulnerability.