Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> SuSE Local Security Checks >> SUSE-SA:2006:059: php4,php5


Vulnerability Assessment Details

SUSE-SA:2006:059: php4,php5

Vulnerability Assessment Summary
Check for the version of the php4,php5 package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory SUSE-SA:2006:059 (php4,php5).


The ini_restore() method could be exploited to reset options such as
open_basedir when set via the web server config file to their default
value set in php.ini (CVE-2006-4625).

Additionally php5 on all products as well as php4 on SLES8 were
vulnerable to an integer overflow problem in the memory
allocation routine. This bug can be exploited to execute
arbitrary code with the uid of the web server (CVE-2006-4812).
Thanks to Stefan Esser for reporting the problem.


Solution : http://www.suse.de/security/http://www.novell.com/linux/security/advisories/2006_59_php.html
Network Security Threat Level: Medium

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2007 Tenable Network Security

Cables, Connectors

HP Omen 15-w252nr 15" (1TB, Intel Core i7-6700HQ, 3.8 GHz, 16GB RAM, GTX...
$650.0
HP Omen 15-w252nr 15Toshiba L200 HDKGB13AKA01 1TB Mobile 2.5 Inch SATA 5400rpm Internal Hard Drive
$49.99
Toshiba L200 HDKGB13AKA01 1TB Mobile 2.5 Inch SATA 5400rpm Internal Hard Drive  pictureHP Pavilion 15.6" Touch - 1TB, Intel Core i7, 2.5GHz, 12GB DDR4, Nvidia Gfx Card
$415.0
HP Pavilion 15.6


Discussions

No Discussions have been posted on this vulnerability.