Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> SuSE Local Security Checks >> SUSE-SA:2006:055: openssl,mozilla-nss


Vulnerability Assessment Details

SUSE-SA:2006:055: openssl,mozilla-nss

Vulnerability Assessment Summary
Check for the version of the openssl,mozilla-nss package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory SUSE-SA:2006:055 (openssl,mozilla-nss).


If an RSA key with exponent 3 is used it may be possible to forge a
PKCS verify the certificate if they are not checking for excess data
in the RSA exponentiation result of the signature.

This problems affects various SSL implementations. This advisory
covers the following implementations:

- OpenSSL (CVE-2006-4339)
- Mozilla NSS (CVE-2006-4340 and CVE-2006-4341)
for SUSE Linux 10.0, 10.1 and SUSE Linux Enterprise 10.

Implementations that are affected and still need to be updated:
- gnutls in all distributions.
- Mozilla NSS before SUSE Linux 10.0 and SUSE Linux Enterprise 10.

The official openssl advisory is here:
http://www.openssl.org/news/secadv_20060905.txt

Some details of the actual technical problem can be found here:
http://www.imc.org/ietf-openpgp/mail-archive/msg14307.html


Solution : http://www.suse.de/security/http://www.novell.com/linux/security/advisories/2006_55_ssl.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2007 Tenable Network Security

Cables, Connectors

Dell PowerEdge R720xd 2x E5-2620 2.0GHz 6 Core 48GB 12x Trays H710P
$1895.0
Dell PowerEdge R720xd 2x E5-2620 2.0GHz 6 Core 48GB 12x Trays H710P pictureDELL POWEREDGE M620 REF E5-2650LV2 1.70GHZ 16GB 1.6TB SSD H710P
$1909.0
DELL POWEREDGE M620 REF E5-2650LV2 1.70GHZ 16GB 1.6TB SSD H710P pictureDell PowerEdge R720xd 2x E5-2620 2.0GHz 6 Core 48GB 12x 2TB 7.2K SAS H710P
$3305.0
Dell PowerEdge R720xd 2x E5-2620 2.0GHz 6 Core 48GB 12x 2TB 7.2K SAS H710P pictureDell PowerEdge R610 2x X5660 2.8GHz 6 Core 48GB 6x 512GB SATA SSD PERC 6/i
$1610.0
Dell PowerEdge R610 2x X5660 2.8GHz 6 Core 48GB 6x 512GB SATA SSD PERC 6/i picture


Discussions

No Discussions have been posted on this vulnerability.