Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> SuSE Local Security Checks >> SUSE-SA:2005:011: curl


Vulnerability Assessment Details

SUSE-SA:2005:011: curl

Vulnerability Assessment Summary
Check for the version of the curl package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory SUSE-SA:2005:011 (curl).


infamous41md@hotpop.com reported a vulnerability in libcurl, the
HTTP/FTP retrieval library. This library is used by lots of programs,
including YaST2 and PHP4.

The NTLM authorization in curl had a buffer overflow in the base64
decoding which permits a remote attacker using a prepared remote
server to execute code for the user using curl.

The Kerberos authorization has a similar bug, but is not compiled
in on SUSE Linux.

This is tracked by the Mitre CVE ID CVE-2005-0490.


Solution : http://www.suse.de/security/advisories/2005_11_curl.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

Vintage 1978 DEC Digital RT-11 RT11 Pocket Guide AV-5287C-TC
$16.95
Vintage 1978 DEC Digital RT-11 RT11 Pocket Guide AV-5287C-TC picturePDP-8 DEC M617 6-4 Input NOR Buffers Vintage DIGITAL
$12.99
PDP-8 DEC  M617 6-4 Input NOR Buffers    Vintage DIGITAL picturePDP-8 DEC R203 TRIPLE FLIP-FLOP Vintage Digital Equipment
$9.99
PDP-8 DEC  R203 TRIPLE FLIP-FLOP Vintage Digital Equipment    picturePDP-8 DEC M360 Variable Delay Vintage DIGITAL
$18.99
PDP-8 DEC  M360 Variable Delay    Vintage DIGITAL picture


Discussions

No Discussions have been posted on this vulnerability.