Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> SuSE Local Security Checks >> SUSE-SA:2005:009: cyrus-imapd


Vulnerability Assessment Details

SUSE-SA:2005:009: cyrus-imapd

Vulnerability Assessment Summary
Check for the version of the cyrus-imapd package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory SUSE-SA:2005:009 (cyrus-imapd).


This update fixes one-byte buffer overruns in the cyrus-imapd IMAP
server package.

Several overruns were fixed in the IMAP annote extension as well as
in cached header handling which can be run by an authenticated user.

Additionally bounds checking in fetchnews was improved to avoid
exploitation by a peer news admin.

Please note that one-byte buffer overflows can not be exploited to
execute arbitrary commands by manipulating the saved registers on
the stack if the compiler used (gcc >= 3) aligns the stack space.

Nevertheless the code behavior may be manipulated by overwriting
local variables. The result is not known but ranges between a
denial-of-service condition and privilege escalation.

This update backports bugfixes from the upstream release of
cyrus-imapd 2.2.11 announced on:

http://asg.web.cmu.edu/archive/message.php?mailbox=archive.info-cyrus&msg=33723


Solution : http://www.suse.de/security/advisories/2005_09_cyrus_imapd.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

HP ProLiant DL380 G7 2x X5680 3.33GHz 6 Core 16GB 8x 300GB 10K SAS P410i 512MB
$1872.0
HP ProLiant DL380 G7 2x X5680 3.33GHz 6 Core 16GB 8x 300GB 10K SAS P410i 512MB pictureDell PowerEdge R720xd 2x E5-2620 2.0GHz 6 Core 96GB 12x 1TB 7.2K SAS H710P
$2890.0
Dell PowerEdge R720xd 2x E5-2620 2.0GHz 6 Core 96GB 12x 1TB 7.2K SAS H710P pictureDell PowerEdge R720xd 2x E5-2640 v2 2.0GHz 8 Core 384GB 12x 1TB 7.2K SATA H710P
$5000.0
Dell PowerEdge R720xd 2x E5-2640 v2 2.0GHz 8 Core 384GB 12x 1TB 7.2K SATA H710P pictureHP ProLiant DL380 G7 2x X5650 2.66GHz 6 Core 144GB 8x 300GB 15K SAS P410i 512MB
$5052.0
HP ProLiant DL380 G7 2x X5650 2.66GHz 6 Core 144GB 8x 300GB 15K SAS P410i 512MB picture


Discussions

No Discussions have been posted on this vulnerability.