Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> SuSE Local Security Checks >> SUSE-SA:2004:038: libtiff


Vulnerability Assessment Details

SUSE-SA:2004:038: libtiff

Vulnerability Assessment Summary
Check for the version of the libtiff package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory SUSE-SA:2004:038 (libtiff).


libtiff is used by image viewers and web browser to view 'TIFF' images.
These usually open and display those images without querying the user,
making a normal system by default vulnerable to exploits of image
library bugs.

Chris Evans found several security related problems during an audit of
the image handling library libtiff, some related to buffer overflows,
some related to integer overflows and similar. This issue is being
tracked by the CVE ID CVE-2004-0803.

Matthias Claasen found a division by zero in libtiff. This is tracked
by the CVE ID CVE-2004-0804.

Further auditing by Dmitry Levin exposed several additional integer
overflows. These are tracked by the CVE ID CVE-2004-0886.

Additionally, iDEFENSE Security located a buffer overflow in the OJPEG
(old JPEG) handling in the SUSE libtiff package. This was fixed by
disabling the old JPEG support and is tracked by the CVE ID CVE-2004-0929.

SUSE wishes to thank all the reporters, auditors, and programmers
for helping to fix these problems.


Solution : http://www.suse.de/security/2004_38_libtiff.html
Network Security Threat Level: High

Networks Security ID: 11506

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Cisco Business Class VOIP Phone CP-8861-K9= IP, Requires Cis
$171.59
Cisco Business Class VOIP Phone CP-8861-K9= IP, Requires Cis pictureOoma Telo VoIP Adapter
$45.0
Ooma Telo VoIP Adapter pictureOoma - Linx Wireless Connector for Ooma Telo VoIP Home Phone Service Devices ...
$24.86
Ooma - Linx Wireless Connector for Ooma Telo VoIP Home Phone Service Devices ... pictureCisco CP-7965G IP Voip Display Telephone Phone 7965G 7965
$30.0
Cisco CP-7965G IP Voip Display Telephone Phone 7965G 7965 picture


Discussions

No Discussions have been posted on this vulnerability.