Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> SuSE Local Security Checks >> SUSE-SA:2003:0009: mod_php4


Vulnerability Assessment Details

SUSE-SA:2003:0009: mod_php4

Vulnerability Assessment Summary
Check for the version of the mod_php4 package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory SUSE-SA:2003:0009 (mod_php4).


The Apache module mod_php4 supports the widely used Web scripting
language PHP.
Under some special circumstances a buffer overflow can be triggered
in mod_php4's wordwrap() function. This buffer overflow can be used
to overwrite heap memory and possibly can lead to remote system
compromise.
Just mod_php4 versions greater than 4.1.2 and less than 4.3.0
are vulnerable. This affects SUSE LINUX 8.1 and all SUSE LINUX
Enterprise Server 8 based products.

There is no temporary fix known. Please install the new packages from
our FTP servers.

After updating the mod_php4 module has to be reloaded by Apache.
This can be done by restarting the apache webserver using the following
command as root:
rcapache restart

Please download the update package for your distribution and verify its
integrity by the methods listed in section 3) of this announcement.
Then, install the package using the command 'rpm -Fhv file.rpm' to apply
the update.

Solution : http://www.suse.de/security/2003_009_mod_php4.html
Network Security Threat Level: Medium

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Dell PowerEdge 2900 Server III 2 x Intel Xenon 2.9GHz, 4GB RAM No HDDs
$140.0
Dell PowerEdge 2900 Server III 2 x Intel Xenon 2.9GHz, 4GB RAM No HDDs pictureDell R410, 1 Intel X5650, 32gb Ram, 146 Go SAS 15K
$579.11
Dell R410, 1 Intel X5650, 32gb Ram, 146 Go SAS 15K pictureDell R410, 1 Intel E5520, 16 Gb Ram, 146 Go SAS 15K
$450.93
Dell R410, 1 Intel E5520, 16 Gb Ram, 146 Go SAS 15K pictureDell R410, 1 Intel X5650, 32gb Ram, 1.8 To SAS 15K
$788.86
Dell R410, 1 Intel X5650, 32gb Ram, 1.8 To SAS 15K picture


Discussions

No Discussions have been posted on this vulnerability.