Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Slackware Local Security Checks >> SSA-2004-119-01 kernel security updates


Vulnerability Assessment Details

SSA-2004-119-01 kernel security updates

Vulnerability Assessment Summary
SSA-2004-119-01 kernel security updates

Detailed Explanation for this Vulnerability Assessment

New kernel packages are available for Slackware 9.1 and -current to
fix security issues. Also available are new kernel modules packages
(including alsa-driver), and a new version of the hotplug package
for Slackware 9.1 containing some fixes for using 2.4.26 (and 2.6.x)
kernel modules.

The most serious of the fixed issues is an overflow in ip_setsockopt(),
which could permit a local attacker to gain root access, or to crash or
reboot the machine. This bug affects 2.4 kernels from 2.4.22 - 2.4.25.
Any sites running one of those kernel versions should upgrade right
away. After installing the new kernel, be sure to run 'lilo'.

More details about the issues may be found in the Common
Vulnerabilities and Exposures (CVE) database:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0394
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0424




Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Michel Arboi

Cables, Connectors

Dell PowerEdge R510 Server 2x2.26GHz Quad Core E5520 32GB PERC6i + 8 Trays
$324.95
Dell PowerEdge R510 Server 2x2.26GHz Quad Core E5520 32GB PERC6i + 8 Trays pictureDELL PowerEdge R620 Server 2x 2.60Ghz E5-2670 8C 128GB 2x 300GB SAS 90D Warranty
$1988.8
DELL PowerEdge R620 Server 2x 2.60Ghz E5-2670 8C 128GB 2x 300GB SAS 90D Warranty pictureDell GM069 PowerConnect M6220 Switch Module for M1000e Blade Server
$23.99
Dell GM069 PowerConnect M6220 Switch Module for M1000e Blade Server pictureDell NC5NP CMC Controller Module for PowerEdge M1000E Storage Server
$22.39
Dell NC5NP CMC Controller Module for PowerEdge M1000E Storage Server picture


Discussions

No Discussions have been posted on this vulnerability.