Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Red Hat Local Security Checks >> RHSA-2006-0725: qt


Vulnerability Assessment Details

RHSA-2006-0725: qt

Vulnerability Assessment Summary
Check for the version of the qt packages

Detailed Explanation for this Vulnerability Assessment


Updated qt packages that correct an integer overflow flaw are now
available.

This update has been rated as having moderate security impact by the Red
Hat Security Response Team.

Qt is a software toolkit that simplifies the task of writing and
maintaining GUI (Graphical User Interface) applications for the X Window
System.

An integer overflow flaw was found in the way Qt handled certain pixmap
images. If an application linked against Qt created a pixmap image in a
certain way, it could lead to a denial of service or possibly permit the
execution of arbitrary code. (CVE-2006-4811)

Users of Qt should upgrade to these updated packages, which contain a
backported patch to correct this issue.




Solution : http://rhn.redhat.com/errata/RHSA-2006-0725.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

Cisco Nexus 2248TP Fabric Extender N2K-C2248TP-1GE 10GE SFP+ uplink
$222.86
Cisco Nexus 2248TP Fabric Extender N2K-C2248TP-1GE 10GE SFP+ uplink  pictureCisco NM-8AM 8 Port Analog Modem Network Module
$10.0
Cisco NM-8AM 8 Port Analog Modem Network Module pictureCisco 2821 2-Port Gigabit Wired Router (CISCO2821)
$0.99
Cisco 2821 2-Port Gigabit Wired Router (CISCO2821) pictureUSED Cisco VIC2-4FXO Four-port Voice Interface Card - FXO
$30.0
USED Cisco VIC2-4FXO Four-port Voice Interface Card - FXO picture


Discussions

No Discussions have been posted on this vulnerability.