Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Red Hat Local Security Checks >> RHSA-2005-829: openssl


Vulnerability Assessment Details

RHSA-2005-829: openssl

Vulnerability Assessment Summary
Check for the version of the openssl packages

Detailed Explanation for this Vulnerability Assessment


Updated OpenSSL packages that fix a remote denial of service vulnerability
are now available for Red Hat Enterprise Linux 2.1

This update has been rated as having important security impact by the Red
Hat Security Response Team.

The OpenSSL toolkit implements Secure Sockets Layer (SSL v2/v3),
Transport Layer Security (TLS v1) protocols, and serves as a full-strength
general purpose cryptography library.

Testing performed by the OpenSSL group using the Codenomicon TLS Test Tool
uncovered a null-pointer assignment in the do_change_cipher_spec()
function. A remote attacker could perform a carefully crafted SSL/TLS
handshake against a server that uses the OpenSSL library in such a way as
to cause OpenSSL to crash. Depending on the server this could lead to a
denial of service. (CVE-2004-0079)

This issue was reported as not affecting OpenSSL versions prior to 0.9.6c,
and testing with the Codenomicon Test Tool showed that OpenSSL 0.9.6b as
shipped in Red Hat Enterprise Linux 2.1 did not crash. However, an
alternative reproducer has been written which shows that this issue does
affect versions of OpenSSL prior to 0.9.6c.

Users of OpenSSL are advised to upgrade to these updated packages, which
contain a patch provided by the OpenSSL group that protects against this
issue.

NOTE: Because server applications are affected by this issue, users are
advised to either restart all services that use OpenSSL functionality or
restart their systems after installing these updates.




Solution : http://rhn.redhat.com/errata/RHSA-2005-829.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

128GB (4x32GB) DDR4 2133L PC4-17000L HP Blade WS460c G9 Memory RAM Upgrade 4Rx4
$1500.0
128GB (4x32GB) DDR4 2133L PC4-17000L HP Blade WS460c G9 Memory RAM Upgrade 4Rx4 pictureNew Transcend TS512MSK64V3N Memory DDR3 1333 MHz 4 GB.
$20.0
New Transcend TS512MSK64V3N Memory DDR3 1333 MHz 4 GB. picture128GB (4x32GB) DDR4 2133L PC4-17000L HP Blade BL660C G9 Memory RAM Upgrade 4Rx4
$1500.0
128GB (4x32GB) DDR4 2133L PC4-17000L HP Blade BL660C G9 Memory RAM Upgrade 4Rx4 pictureSamsung (1x8GB) 2Rx4 PC3-10600R ECC DRR3 Server Memory - M393B1K70BH1-CH9
$14.0
Samsung (1x8GB) 2Rx4 PC3-10600R ECC DRR3 Server Memory - M393B1K70BH1-CH9 picture


Discussions

No Discussions have been posted on this vulnerability.