Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Red Hat Local Security Checks >> RHSA-2005-799: irb


Vulnerability Assessment Details

RHSA-2005-799: irb

Vulnerability Assessment Summary
Check for the version of the irb packages

Detailed Explanation for this Vulnerability Assessment


Updated ruby packages that fix an arbitrary command execution issue are now
available.

This update has been rated as having moderate security impact by the Red
Hat Security Response Team.

Ruby is an interpreted scripting language for object-oriented programming.

A bug was found in the way ruby handles eval statements. It is possible for
a malicious script to call eval in such a way that can permit the bypass of
certain safe-level restrictions. The Common Vulnerabilities and Exposures
project (cve.mitre.org) has assigned the name CVE-2005-2337 to this issue.

Users of Ruby should update to these erratum packages, which contain a
backported patch and are not vulnerable to this issue.




Solution : http://rhn.redhat.com/errata/RHSA-2005-799.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

APPLE COMPUTER VINTAGE MAC OS BUTTON *MINT*
$28.95
APPLE COMPUTER VINTAGE MAC OS BUTTON *MINT*  pictureVintage Apple Extended Keyboard II M3501, no ADB cable, tested working on Mac
$38.95
Vintage Apple Extended Keyboard II M3501, no ADB cable, tested working on Mac  pictureVintage 1990 Mac Macintosh Basics 3.5" Floppy Disk Software Disc
$25.0
Vintage 1990 Mac Macintosh Basics 3.5VINTAGE APPLE EE-MAC-HH-CO-US/200420 EXTERNAL HARD DRIVE TESTED FOR POWER UP
$94.04
VINTAGE APPLE EE-MAC-HH-CO-US/200420 EXTERNAL HARD DRIVE TESTED FOR POWER UP picture


Discussions

No Discussions have been posted on this vulnerability.