Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Red Hat Local Security Checks >> RHSA-2004-494: ImageMagick


Vulnerability Assessment Details

RHSA-2004-494: ImageMagick

Vulnerability Assessment Summary
Check for the version of the ImageMagick packages

Detailed Explanation for this Vulnerability Assessment


Updated ImageMagick packages that fix various security vulnerabilities are
now available.

ImageMagick(TM) is an image display and manipulation tool for the X Window
System.

A heap overflow flaw was discovered in the ImageMagick image handler.
A possible hacker could create a carefully crafted BMP file in such a way that it
would cause ImageMagick to execute arbitrary code when processing the
image. The Common Vulnerabilities and Exposures project (cve.mitre.org)
has assigned the name CVE-2004-0827 to this issue.

A temporary file handling bug has been found in ImageMagick's libmagick
library. A local user could overwrite or create files as a different user
if a program was linked with the vulnerable library. The Common
Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name
CVE-2003-0455 to this issue.

Users of ImageMagick should upgrade to these updated packages, which
contain a backported patch, and is not vulnerable to this issue.




Solution : http://rhn.redhat.com/errata/RHSA-2004-494.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

LENOVO THINKSERVER NEW RD350 TWO E5-2620V3 2.4GHZ 96GB NO HDD
$1879.0
LENOVO THINKSERVER NEW RD350 TWO E5-2620V3 2.4GHZ 96GB NO HDD pictureLENOVO THINKSERVER RD650 E5-2690V4 2.6GHZ 4 X 8GB NO HDD
$3209.0
LENOVO THINKSERVER RD650 E5-2690V4 2.6GHZ 4 X 8GB NO HDD pictureLENOVO THINKSERVER RD650 TWO E5-2697AV4 2.6GHZ 2 X 8GB NO HDD
$7149.0
LENOVO THINKSERVER RD650 TWO E5-2697AV4 2.6GHZ 2 X 8GB NO HDD pictureLENOVO THINKSERVER RD650 TWO E5-2698V4 2.2GHZ 8 X 8GB NO HDD
$7939.0
LENOVO THINKSERVER RD650 TWO E5-2698V4 2.2GHZ 8 X 8GB NO HDD picture


Discussions

No Discussions have been posted on this vulnerability.