Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Red Hat Local Security Checks >> RHSA-2004-084: httpd


Vulnerability Assessment Details

RHSA-2004-084: httpd

Vulnerability Assessment Summary
Check for the version of the httpd packages

Detailed Explanation for this Vulnerability Assessment


Updated httpd packages are now available that fix a denial of service
vulnerability in mod_ssl and include various other bug fixes.

The Apache HTTP server is a powerful, full-featured, efficient, and
freely-available Web server.

A memory leak in mod_ssl in the Apache HTTP Server prior to version 2.0.49
permits a remote denial of service attack against an SSL-enabled server. The
Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned
the name CVE-2004-0113 to this issue.

This update also includes various bug fixes, including:

- improvements to the mod_expires, mod_dav, mod_ssl and mod_proxy modules

- a fix for a bug causing core dumps during configuration parsing on the
IA64 platform

- an updated version of mod_include fixing several edge cases in the SSI
parser

Additionally, the mod_logio module is now included.

Users of the Apache HTTP server should upgrade to these updated packages,
which contain backported patches that address these issues.




Solution : http://rhn.redhat.com/errata/RHSA-2004-084.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

VA Linux 1221 1U Dual Pentium III 1GHz / 3GB SDRAM / 18GB SCSI Pfsense TESTED
$93.49
VA Linux 1221 1U Dual Pentium III 1GHz / 3GB SDRAM / 18GB SCSI Pfsense TESTED pictureMicrosoft SQL Server 2017 Standard No User CAL Required 16 Core License + USB
$299.99
Microsoft SQL Server 2017 Standard No User CAL Required 16 Core License + USB pictureM2 to pci-e adapter Converter 1pc For IOS windows8/10 linux IU server Connector
$8.07
M2 to pci-e adapter Converter 1pc For IOS windows8/10 linux IU server Connector pictureCyclades TS2000 TS-2000 32 Port Terminal Console Server Switch Rackmount Linux
$75.0
Cyclades TS2000 TS-2000 32 Port Terminal Console Server Switch Rackmount Linux picture


Discussions

No Discussions have been posted on this vulnerability.