Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Red Hat Local Security Checks >> RHSA-2004-041: slocate


Vulnerability Assessment Details

RHSA-2004-041: slocate

Vulnerability Assessment Summary
Check for the version of the slocate packages

Detailed Explanation for this Vulnerability Assessment


Updated slocate packages are now available that fix vulnerabilities
permiting a local user to gain "slocate" group rights.

Slocate is a security-enhanced version of locate, designed to find files on
a system via a central database.

Patrik Hornik discovered a vulnerability in Slocate versions up to and
including 2.7 where a carefully crafted database could overflow a
heap-based buffer. A local user could exploit this vulnerability to gain
"slocate" group rights and then read the entire slocate database. The
Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned
the name CVE-2003-0848 to this issue.

Users of Slocate should upgrade to these erratum packages, which contain
Slocate version 2.7 with the addition of a patch from Kevin Lindsay that
causes slocate to drop rights before reading a user-supplied database.

For Red Hat Enterprise Linux 2.1 these packages also fix a buffer overflow
that affected unpatched versions of Slocate prior to 2.7. This
vulnerability could also permit a local user to gain "slocate" group
rights. The Common Vulnerabilities and Exposures project
(cve.mitre.org) has assigned the name CVE-2003-0056 to this issue.




Solution : http://rhn.redhat.com/errata/RHSA-2004-041.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Dell R720 8-Core Server 2x E5-2609 v2 2.5GHz 16GB 8x 480GB SSD H710 2.5in Rails
$2596.0
Dell R720 8-Core Server 2x E5-2609 v2 2.5GHz 16GB 8x 480GB SSD H710 2.5in Rails pictureDELL POWEREDGE R710 TWO E5520 2.26GHZ 128GB 6 X 600GB 10K SAS PERC 6/I
$2009.0
DELL POWEREDGE R710 TWO E5520 2.26GHZ 128GB 6 X 600GB 10K SAS PERC 6/I pictureDell R720 8-Core Server 2x E5-2609 v2 2.5GHz 128GB 16x 600GB H710P 2.5in 16 Bay
$2567.0
Dell R720 8-Core Server 2x E5-2609 v2 2.5GHz 128GB 16x 600GB H710P 2.5in 16 Bay pictureDELL POWEREDGE M620 BLADE TWO E5-2660V2 2.20GHZ 96GB 2 X 300GB 10K SAS H310
$1499.0
DELL POWEREDGE M620 BLADE TWO E5-2660V2 2.20GHZ 96GB 2 X 300GB 10K SAS H310 picture


Discussions

No Discussions have been posted on this vulnerability.