Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Red Hat Local Security Checks >> RHSA-2004-015: httpd


Vulnerability Assessment Details

RHSA-2004-015: httpd

Vulnerability Assessment Summary
Check for the version of the httpd packages

Detailed Explanation for this Vulnerability Assessment


Updated httpd packages that fix two minor security issues in the Apache Web
server are now available for Red Hat Enterprise Linux 3.

The Apache HTTP Server is a powerful, full-featured, efficient, and
freely-available Web server.

An issue in the handling of regular expressions from configuration files
was discovered in releases of the Apache HTTP Server version 2.0 prior to
2.0.48. To exploit this issue a possible hacker would need to have the ability
to write to Apache configuration files such as .htaccess or httpd.conf. A
carefully-crafted configuration file can cause an exploitable buffer
overflow and would permit the attacker to execute arbitrary code in the
context of the server (in default configurations as the 'apache' user).
The Common Vulnerabilities and Exposures project (cve.mitre.org) has
assigned the name CVE-2003-0542 to this issue.

Users of the Apache HTTP Server should upgrade to these erratum packages,
which contain backported patches correcting these issues, and are applied
to Apache version 2.0.46. This update also includes fixes for a number of
minor bugs found in this version of the Apache HTTP Server.




Solution : http://rhn.redhat.com/errata/RHSA-2004-015.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Dell R630 16-Core Server 2x E5-2630 v3 2.4GHz 512GB H730 8x 1TB iDRAC Rails RPS
$8678.0
Dell R630 16-Core Server 2x E5-2630 v3 2.4GHz 512GB H730 8x 1TB iDRAC Rails RPS pictureDELL POWEREDGE R730XD SERVER 12 BAY E5-2650V3 2.3GHZ 256GB 1TB SATA H730
$5629.0
DELL POWEREDGE R730XD SERVER 12 BAY E5-2650V3 2.3GHZ 256GB 1TB SATA H730 pictureDell Inspiron Desktop Intel Core I5 3.3ghz 8gb RAM 1tb HD DVD Win 10
$110.0
Dell Inspiron Desktop Intel Core I5 3.3ghz 8gb RAM 1tb HD DVD Win 10 pictureHP Z820 WORKSTATION W7 PRO E5-2660V2 2.20GHZ 48GB 1TB SATA QUADRO K4000 3GB
$3229.0
HP Z820 WORKSTATION W7 PRO E5-2660V2 2.20GHZ 48GB 1TB SATA QUADRO K4000 3GB picture


Discussions

No Discussions have been posted on this vulnerability.