Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Red Hat Local Security Checks >> RHSA-2004-002: ethereal


Vulnerability Assessment Details

RHSA-2004-002: ethereal

Vulnerability Assessment Summary
Check for the version of the ethereal packages

Detailed Explanation for this Vulnerability Assessment


Updated Ethereal packages that fix two security vulnerabilities are now
available.

Ethereal is a program for monitoring network traffic.

Two security issues have been found that affect Ethereal. By exploiting
these issues it may be possible to make Ethereal crash by injecting an
intentionally malformed packet onto the wire or by convincing someone to
read a malformed packet trace file. It is not known if these issues could
permit arbitrary code execution.

The SMB dissector in Ethereal before 0.10.0 permits remote attackers to
cause a denial of service via a malformed SMB packet that triggers a
segmentation fault during processing of Selected packets. The Common
Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name
CVE-2003-1012 to this issue.

The Q.931 dissector in Ethereal before 0.10.0 permits remote attackers to
cause a denial of service (crash) via a malformed Q.931, which triggers a
null dereference. The Common Vulnerabilities and Exposures project
(cve.mitre.org) has assigned the name CVE-2003-1013 to this issue.

Users of Ethereal should update to these erratum packages containing
Ethereal version 0.10.0, which is not vulnerable to these issues.




Solution : http://rhn.redhat.com/errata/RHSA-2004-002.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

DELL POWEREDGE M620 BLADE E5-2650LV2 1.70GHZ 32GB NO HDD H710
$1149.0
DELL POWEREDGE M620 BLADE E5-2650LV2 1.70GHZ 32GB NO HDD H710 pictureDELL POWEREDGE M630 TWO E5-2630V3 2.4GHZ 64GB 2 X 1TB SATA S130
$2659.0
DELL POWEREDGE M630 TWO E5-2630V3 2.4GHZ 64GB 2 X 1TB SATA S130 pictureDELL POWEREDGE M630 E5-2643V4 3.4GHZ 96GB 1.8TB 10K 12G H730
$3869.0
DELL POWEREDGE M630 E5-2643V4 3.4GHZ 96GB 1.8TB 10K 12G H730 pictureCisco UCS C210 M2 2U Server: 2x E5640 2.67GHz - 48GB - 2x 147GB (R210-2121605W)
$602.36
Cisco UCS C210 M2 2U Server: 2x E5640 2.67GHz - 48GB - 2x 147GB (R210-2121605W) picture


Discussions

No Discussions have been posted on this vulnerability.