Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Red Hat Local Security Checks >> RHSA-2003-114: mod_auth_any


Vulnerability Assessment Details

RHSA-2003-114: mod_auth_any

Vulnerability Assessment Summary
Check for the version of the mod_auth_any packages

Detailed Explanation for this Vulnerability Assessment


Updated mod_auth_any packages are available for Red Hat Enterprise Linux.
These updated packages fix vulnerabilities associated with the manner in
which mod_auth_any escapes shell arguments when calling external programs.

The Web server module mod_auth_any permits the Apache httpd server to
call arbitrary external programs to verify user passwords.

Vulnerabilities have been found in versions of mod_auth_any included in Red
Hat Enterprise Linux concerning the method by which mod_auth_any escapes
shell arguments when calling external programs. These vulnerabilities
permit remote attackers to run arbitrary commands as the user under which
the Web server is running. The Common Vulnerabilities and Exposures
project (cve.mitre.org) has assigned the name CVE-2003-0084 to these
issues.

All users are advised to upgrade to these errata packages, which change the
method by which external programs are invoked and, therefore, make these
programs invulnerable to these issues.

Red Hat would like to thank Daniel Jarboe and Maneesh Sahani for bringing
these issues to our attention.




Solution : http://rhn.redhat.com/errata/RHSA-2003-114.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

HP G7 2291NR 15" AMD Quad-Core A6-4400M 2.7GHz 8GB 1TB Windows 10 Broken Parts
$80.0
HP G7 2291NR 15Dell Latitude E6440 Intel Core i5-4310M 2.7GHz 500GB HDD 8GB DVDRW HDMI W10 PRO
$250.0
Dell Latitude E6440 Intel Core i5-4310M 2.7GHz 500GB HDD 8GB DVDRW HDMI W10 PRO picture15" Apple MacBook Pro 2010 2.53GHz Core i5 500GB 7200RPM HD 8GB RAM + WARRANTY
$589.99
15DELL PowerEdge R410 Server 2x 2.26Ghz L5520 QC 32GB 4x 2TB 90D Warranty
$609.4
DELL PowerEdge R410 Server 2x 2.26Ghz L5520 QC 32GB 4x 2TB 90D Warranty picture


Discussions

No Discussions have been posted on this vulnerability.