Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Red Hat Local Security Checks >> RHSA-2003-077: ethereal


Vulnerability Assessment Details

RHSA-2003-077: ethereal

Vulnerability Assessment Summary
Check for the version of the ethereal packages

Detailed Explanation for this Vulnerability Assessment


Updated Ethereal packages fixing a number of remotely exploitable security
issues are now available.

Ethereal is a package designed for monitoring network traffic.

A number of security issues affect Ethereal. By exploiting these issues it
may be possible to make Ethereal crash or run arbitrary code by injecting a
purposefully malformed packet onto the wire, or by convincing someone to
read a malformed packet trace file.

Ethereal 0.9.9 and earlier permits remote attackers to cause a denial
of service (crash) and possibly execute arbitrary code via carefully
crafted SOCKS packets. The Common Vulnerabilities and Exposures project
(cve.mitre.org) has assigned the name CVE-2003-0081 to this issue.

A heap-based buffer overflow exists in the NTLMSSP code for Ethereal
0.9.9 and earlier. (CVE-2003-0159)

Multiple off-by-one vulnerabilities exist in Ethereal 0.9.11 and earlier in
the AIM, GIOP Gryphon, OSPF, PPTP, Quake, Quake2, Quake3, Rsync, SMB, SMPP,
and TSP dissectors, which do not properly use the tvb_get_nstringz and
tvb_get_nstringz0 functions. (CVE-2003-0356)

Multiple integer overflow vulnerabilities exist in Ethereal 0.9.11 and
earlier in the Mount and PPP dissectors. (CVE-2003-0357)

A vulnerability in the DCERPC dissector exists in Ethereal 0.9.12 and
earlier, permiting remote attackers to cause a denial of service (memory
consumption) via a certain NDR string. (CVE-2003-0428)

A possible buffer overflow vulnerability exists in Ethereal 0.9.12 and
earlier, caused by invalid IPv4 or IPv6 prefix lengths and possibly
triggering a buffer overflow. (CVE-2003-0429)

A vulnerability exists in Ethereal 0.9.12 and earlier, permiting remote
attackers to cause a denial of service (crash) via an invalid ASN.1 value.
(CVE-2003-0430)

The tvb_get_nstringz0 function in Ethereal 0.9.12 and earlier does not
properly handle a zero-length buffer size. (CVE-2003-0431)

Ethereal 0.9.12 and earlier does not handle certain strings properly in the
BGP, WTP, DNS, 802.11, ISAKMP, WSP, CLNP, ISIS, and RMI dissectors.
(CVE-2003-0432)

Users of Ethereal should update to these erratum packages containing
Ethereal version 0.9.13, which are not vulnerable to these issues.




Solution : http://rhn.redhat.com/errata/RHSA-2003-077.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Latest KNOPPIX LINUX Operating system PC repair Bootable live system Windows USB
$19.99
Latest KNOPPIX LINUX Operating system PC repair Bootable live system Windows USB pictureKnoppix 7.2.0 Live Linux Bootable Startup CD (Runs form CD) +Free Retro Linux CD
$11.95
Knoppix 7.2.0 Live Linux Bootable Startup CD (Runs form CD) +Free Retro Linux CD pictureKNOPPIX LINUX - NEW v8.1 Live DVD & 16GB USB Flash Drive with Persistence
$17.99
KNOPPIX LINUX - NEW v8.1 Live DVD & 16GB USB Flash Drive with Persistence pictureKnoppix Linux Live USB 32 64 bit Debian GNU Apache MySQL w/setup guide
$8.0
Knoppix Linux Live USB 32 64 bit Debian GNU Apache MySQL w/setup guide picture


Discussions

No Discussions have been posted on this vulnerability.