Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Red Hat Local Security Checks >> RHSA-2003-048: python


Vulnerability Assessment Details

RHSA-2003-048: python

Vulnerability Assessment Summary
Check for the version of the python packages

Detailed Explanation for this Vulnerability Assessment


An insecure use of a temporary file has been found in Python.

Python is an interpreted, interactive, object-oriented programming
language.

Zack Weinberg discovered that os._execvpe from os.py in Python 2.2.1 and
earlier creates temporary files with predictable names. This could permit
local users to execute arbitrary code via a symlink attack

All users should upgrade to these errata packages which include a patch to
python 1.5.2 to correct this issue.




Solution : http://rhn.redhat.com/errata/RHSA-2003-048.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

TRENDnet 100Base-FX SFP Multi-Mode LC Module, Compatible with Mini-GBIC, Suppor
$93.73
TRENDnet 100Base-FX SFP Multi-Mode LC Module, Compatible with Mini-GBIC, Suppor picture10 Gigabit SFP+ LC Single-Mode Transceiver, 10GBASE-LR Module for Intel E... New
$52.99
10 Gigabit SFP+ LC Single-Mode Transceiver, 10GBASE-LR Module for Intel E... New pictureCisco WS-C4500X-32SFP+ network switch Managed Grey
$32534.42
Cisco WS-C4500X-32SFP+ network switch Managed Grey pictureCisco Original SFP-10G-SR V02 Transceiver Modules 10-2415-02
$19.99
Cisco Original SFP-10G-SR V02 Transceiver Modules 10-2415-02 picture


Discussions

No Discussions have been posted on this vulnerability.