Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Red Hat Local Security Checks >> RHSA-2003-008: mgetty


Vulnerability Assessment Details

RHSA-2003-008: mgetty

Vulnerability Assessment Summary
Check for the version of the mgetty packages

Detailed Explanation for this Vulnerability Assessment


Updated Mgetty packages are now available to fix a possible buffer overflow
and a permissions problem.

Mgetty is a getty replacement for use with data and fax modems.

Mgetty can be configured to run an external program to decide whether or
not to answer an incoming call based on Caller ID information. Versions of
Mgetty prior to 1.1.29 would overflow an internal buffer if the caller name
reported by the modem was too long.

Additionally, the faxspool script supplied with versions of Mgetty prior to
1.1.29 used a simple permissions scheme to permit or deny fax transmission
rights. This scheme was easily circumvented because the spooling
directory used for outgoing faxes was world-writable.

All users of Mgetty should upgrade to these errata packages, which
contain Mgetty 1.1.30 and are not vulnerable to these issues.




Solution : http://rhn.redhat.com/errata/RHSA-2003-008.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

DELL POWEREDGE M620 BLADE TWO E5-2620V2 2.10GHZ 512GB 2 X 1TB SATA H310
$6369.0
DELL POWEREDGE M620 BLADE TWO E5-2620V2 2.10GHZ 512GB 2 X 1TB SATA H310 pictureDELL POWEREDGE M630 E5-2690V3 2.6GHZ 64GB 2 X 1.8TB 10K SAS H730
$4379.0
DELL POWEREDGE M630 E5-2690V3 2.6GHZ 64GB 2 X 1.8TB 10K SAS H730 pictureHP PROLIANT SL250S G8 LEFT SERVER E5-2660 2.2GHZ 32GB 2 X 1TB SATA
$829.0
HP PROLIANT SL250S G8 LEFT SERVER E5-2660 2.2GHZ 32GB 2 X 1TB SATA pictureDELL POWEREDGE M620 BLADE E5-2603 1.80GHZ 8GB 250GB SATA H710
$1009.0
DELL POWEREDGE M620 BLADE E5-2603 1.80GHZ 8GB 250GB SATA H710 picture


Discussions

No Discussions have been posted on this vulnerability.