Vulnerability Assessment & Network Security Forums
If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important. If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.
Vulnerability Assessment Details
Check for the version of the Canna packages
Detailed Explanation for this Vulnerability Assessment
The Canna server, used for Japanese character input, has two security
vulnerabilities including an exploitable buffer overflow that permits a
user to gain 'bin' user rights. Updated packages for Red Hat Linux
Advanced Server are available.
[Updated 13 Jan 2003]
Added fixed packages for the Itanium (IA64) architecture.
[Updated 06 Feb 2003]
Added fixed packages for Advanced Workstation 2.1
Canna is a kana-kanji conversion server which is necessary for Japanese
language character input.
A buffer overflow bug in the Canna server up to and including version 3.5b2
permits a local user to gain the rights of the user 'bin' which can
lead to further exploits. The Common Vulnerabilities and Exposures project
(cve.mitre.org) has assigned the name CVE-2002-1158 to this issue.
In addition, it was discovered that request validation was lacking in Canna
server versions 3.6 and earlier. A malicious remote user could exploit this
vulnerability to leak information or cause a denial of service attack.
Red Hat Linux Advanced Server ships with a Canna package vulnerable
to these issues
however, the package is normally only installed when
Japanese language support is selected during installation.
All users of Canna are advised to upgrade to these errata packages which
contain a backported security fix and are not vulnerable to this issue.
Red Hat would like to thank hsj and AIDA Shinra for the responsible
disclosure of these issues.
Solution : http://rhn.redhat.com/errata/RHSA-2002-261.html
Network Security Threat Level: High
Networks Security ID:
Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security
|DELL POWEREDGE M820 SERVER FOUR E5-4650 8C 2.7GHZ 16GB 3 X 600GB SSD H710
|DELL POWEREDGE M820 TWO E5-4620 2.2GHZ 64GB 480GB SSD H710
|HP PROLIANT BL460C G8 SERVER E5-2667 2.90GHZ 64GB 2 X 300GB 15K SAS
No Discussions have been posted on this vulnerability.