Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Red Hat Local Security Checks >> RHSA-2002-256: wget


Vulnerability Assessment Details

RHSA-2002-256: wget

Vulnerability Assessment Summary
Check for the version of the wget packages

Detailed Explanation for this Vulnerability Assessment


The wget packages shipped with Red Hat Linux Advanced Server 2.1 contain a
security bug which, under certain circumstances, can cause local files to
be written outside the download directory.

[Updated 09 Jan 2003]
Added fixed packages for the Itanium (IA64) architecture.

[Updated 06 Feb 2003]
Added fixed packages for Advanced Workstation 2.1

Versions of wget prior to 1.8.2-4 contain a bug that permits a malicious
FTP server to create or overwrite files anywhere on the local file system.

FTP clients must check to see if an FTP server's response to the NLST
command includes any directory information along with the list of filenames
required by the FTP protocol (RFC 959, section 4.1.3).

If the FTP client fails to do so, a malicious FTP server can send filenames
beginning with '/' or containing '/../' which can be used to direct a
vulnerable FTP client to write files (such as .forward, .rhosts, .shost,
etc.) that can then be used for later attacks against the client machine.

All users of wget should upgrade to the errata packages which are not
vulnerable to this issue.

Thanks to Steven M. Christey for his work in discovering this issue
in current FTP clients and for providing a patched FTP server to verify
the new packages.




Solution : http://rhn.redhat.com/errata/RHSA-2002-256.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Robust Enterprise DELL PowerEdge R710 Server 12-Core 64GB 3x 160GB SSD 5x 500GB
$903.1
Robust Enterprise DELL PowerEdge R710 Server 12-Core 64GB 3x 160GB SSD 5x 500GB pictureDell PowerEdge R620 Server Dual Xeon E5-2690 8C 2.9GHz 64GB 5x 500GB 10 Bay
$1112.0
Dell PowerEdge R620 Server Dual Xeon E5-2690 8C 2.9GHz 64GB 5x 500GB 10 Bay pictureDell PowerEdge R620 Server Dual E5-2690 8C 2.9GHz 64GB 10x 1TB SAS 10 Bay
$1910.0
Dell PowerEdge R620 Server Dual E5-2690 8C 2.9GHz 64GB 10x 1TB SAS 10 Bay pictureDell PowerEdge R720 Server Dual Xeon E5-2670 8C 2.6GHz 24GB 8x 1TB iDRAC 2.5in
$1346.0
Dell PowerEdge R720 Server Dual Xeon E5-2670 8C 2.6GHz 24GB 8x 1TB iDRAC 2.5in picture


Discussions

No Discussions have been posted on this vulnerability.